Every CVE Search/ Get API key

CVE-2017-1000228

ejs is vulnerable to remote code execution due to weak input validation

9.8 CriticalFix available

nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

6.38%Up 5.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function

Record
CVE-2017-1000228
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function

Record
CVE-2017-1000228
Updated
2026-11-02
EUVDEUVD-2017-0340 No score

nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function

Record
EUVD-2017-0340
Updated
2026-11-03
GitHub AdvisoriesGHSA-3w5v-p54c-f74x 9.8

ejs is vulnerable to remote code execution due to weak input validation

nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function

Record
GHSA-3w5v-p54c-f74x
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 9.8

nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function

Record
CVE-2017-1000228
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-1000228 9.8

nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function

Record
DEBIAN-CVE-2017-1000228
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-3w5v-p54c-f74x 9.8

ejs is vulnerable to remote code execution due to weak input validation

nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function

Record
GHSA-3w5v-p54c-f74x
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVCLSA-2026-1774570929 No score

TuxCare security update for ejs (5 CVEs)

TuxCare rebuilt ejs to address 5 CVEs. Fixed in 1.0.0-tuxcare.1.

Record
CLSA-2026-1774570929
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ejs
npm
before 2.5.3
2.5.3
ejs
TuxCare:npm
From an advisory covering 5 CVEs
1.0.0-tuxcare.0 up to 1.0.0-tuxcare.1, plus listed versions
1.0.0
1.0.0-tuxcare.1
node-ejs
Debian:12
before 2.5.7-1
2.5.7-1
node-ejs
Debian:13
before 2.5.7-1
2.5.7-1
node-ejs
Debian:14
before 2.5.7-1
2.5.7-1
ejs
npm
before 2.5.5
2.5.5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-1000228 is a critical vulnerability (CVSS 9.8) in Ejs, published November 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.38%, the 93rd percentile. Fixed in ejs 2.5.3.

References

MoveEnter Open