CVE-2017-1000242
Insecure temporary file usage in Jenkins Git Client Plugin
Jenkins Git Client Plugin 2.4.2 and earlier creates temporary file with insecure permissions resulting in information disclosure
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
3.3
Jenkins Git Client Plugin 2.4.2 and earlier creates temporary file with insecure permissions resulting in information disclosure
- Record
CVE-2017-1000242- CVSS 3.0
- 3.3 Low
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - CVSS 2.0
- 2.1 Low
AV:L/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
Jenkins Git Client Plugin 2.4.2 and earlier creates temporary file with insecure permissions resulting in information disclosure
- Record
CVE-2017-1000242- Updated
- 2026-11-02
EUVDEUVD-2022-3754 No score
Jenkins Git Client Plugin 2.4.2 and earlier creates temporary file with insecure permissions resulting in information disclosure
- Record
EUVD-2022-3754- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fcxw-hhxq-48wx
3.3
Insecure temporary file usage in Jenkins Git Client Plugin
Jenkins Git Client Plugin 2.4.2 and earlier creates temporary file with insecure permissions resulting in information disclosure
- Record
GHSA-fcxw-hhxq-48wx- CVSS 3.0
- 3.3 Low
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSV
3.3
Jenkins Git Client Plugin 2.4.2 and earlier creates temporary file with insecure permissions resulting in information disclosure
- Record
CVE-2017-1000242- CVSS 3.0
- 3.3 Low
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-fcxw-hhxq-48wx
3.3
Insecure temporary file usage in Jenkins Git Client Plugin
Jenkins Git Client Plugin 2.4.2 and earlier creates temporary file with insecure permissions resulting in information disclosure
- Record
GHSA-fcxw-hhxq-48wx- CVSS 3.0
- 3.3 Low
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jenkins-ci.plugins:git-clientMaven |
before 2.4.3 | 2.4.3 |
org.jenkins-ci.plugins:git-clientMaven |
before 2.4.3, plus listed versions 1.0.21.0.31.0.41.0.51.0.6 Show 45 moreShow less1.0.71.11.1.11.1.21.10.01.10.11.10.21.11.01.11.11.12.01.13.01.14.01.14.11.15.01.16.11.17.01.17.11.18.01.19.01.19.11.19.21.19.31.19.41.19.51.19.61.19.71.2.01.20.0-beta11.20.0-beta21.20.0-beta31.20.21.21.01.3.01.4.01.4.11.4.21.4.31.4.41.4.51.4.61.5.01.5.11.6.01.6.11.6.2 |
2.4.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000242 is a low vulnerability (CVSS 3.3) in Jenkins Git Client, published November 1, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 32nd percentile. Fixed in org.jenkins-ci.plugins:git-client 2.4.3.
References
Left out here: 22 versions. The JSON record has them.