CVE-2017-1000510
Cross site scripting in Croogo
Croogo version 2.3.1-17-g6f82e6c contains a Cross Site Scripting (XSS) vulnerability in Page name that can result in execution of javascript code.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
Croogo version 2.3.1-17-g6f82e6c contains a Cross Site Scripting (XSS) vulnerability in Page name that can result in execution of javascript code.
- Record
CVE-2017-1000510- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Croogo version 2.3.1-17-g6f82e6c contains a Cross Site Scripting (XSS) vulnerability in Page name that can result in execution of javascript code.
- Record
CVE-2017-1000510- Updated
- 2026-11-02
EUVDEUVD-2022-5086 No score
Croogo version 2.3.1-17-g6f82e6c contains a Cross Site Scripting (XSS) vulnerability in Page name that can result in execution of javascript code.
- Record
EUVD-2022-5086- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-r4h9-gv2m-9x97
5.4
Cross site scripting in Croogo
Croogo versions before 4.x contain a Cross Site Scripting (XSS) vulnerability in Page name that can result in execution of javascript code.
- Record
GHSA-r4h9-gv2m-9x97- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-r4h9-gv2m-9x97
5.4
Cross site scripting in Croogo
Croogo versions before 4.x contain a Cross Site Scripting (XSS) vulnerability in Page name that can result in execution of javascript code.
- Record
GHSA-r4h9-gv2m-9x97- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
croogo/croogoPackagist |
before 4.0.0 | 4.0.0 |
croogo/croogoPackagist |
before 4.0.0, plus listed versions 2.3.33.0.03.0.0-alpha.13.0.0-alpha.23.0.0-alpha.3 Show 26 moreShow less3.0.0-alpha.43.0.0-beta.13.0.13.0.23.0.33.0.43.0.53.0.63.0.74.0.0-alpha.24.0.0-beta.14.0.0-beta.24.0.0-beta.34.0.0-beta.4v2.0.0v2.1.0v2.1.1v2.1.2v2.2.0v2.2.1v2.2.2v2.2.3v2.2.4v2.3.0v2.3.1v2.3.2 |
4.0.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000510 is a medium vulnerability (CVSS 5.4) in Croogo, published February 9, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.76%, the 55th percentile. Fixed in croogo/croogo 4.0.0.