CVE-2017-1002157
modulemd uses an unsafe function for processing externally provided data
modulemd 1.3.1 and earlier uses an unsafe function for processing externally provided data, leading to remote code execution.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
modulemd 1.3.1 and earlier uses an unsafe function for processing externally provided data, leading to remote code execution.
- Record
CVE-2017-1002157- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-242, CWE-20
- Updated
- 2026-11-02
CVE List No score
modulemd 1.3.1 and earlier uses an unsafe function for processing externally provided data, leading to remote code execution.
- Record
CVE-2017-1002157- Weakness
- CWE-242
- Updated
- 2026-11-02
EUVDEUVD-2019-0088 No score
modulemd 1.3.1 and earlier uses an unsafe function for processing externally provided data, leading to remote code execution.
- Record
EUVD-2019-0088- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jhjh-ghwx-6h7r
9.3
modulemd uses an unsafe function for processing externally provided data
modulemd 1.3.1 and earlier uses an unsafe function for processing externally provided data, leading to remote code execution.
- Record
GHSA-jhjh-ghwx-6h7r- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-242
- Updated
- 2026-11-02
OSVGHSA-jhjh-ghwx-6h7r
9.3
modulemd uses an unsafe function for processing externally provided data
modulemd 1.3.1 and earlier uses an unsafe function for processing externally provided data, leading to remote code execution.
- Record
GHSA-jhjh-ghwx-6h7r- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-242
- Updated
- 2026-11-02
OSVPYSEC-2019-153 No score
modulemd 1.3.1 and earlier uses an unsafe function for processing externally provided data, leading to remote code execution.
- Record
PYSEC-2019-153- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1002157 is a critical vulnerability (CVSS 9.8) in Fedora Modularity Modulemd, published January 10, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.88%, the 86th percentile. Fixed in modulemd 1.3.2.