CVE-2017-10140
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might...
CVE-2017-10140 is a high vulnerability (CVSS 7.8) in Postfix, published August 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.55%, the 45th percentile. Fixed in db5.3 5.3.28-13.1.
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might allow local users to gain privileges by leveraging undocumented functionality in Berkeley DB 2.x and later, related to reading settings from DB_CONFIG in the current directory.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might allow local users to gain privileges by leveraging undocumented functionality in Berkeley DB 2.x and later, related to reading settings from DB_CONFIG in the current directory.
- Record
CVE-2017-10140- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might allow local users to gain privileges by leveraging undocumented functionality in Berkeley DB 2.x and later, related to reading settings from DB_CONFIG in the current directory.
- Record
CVE-2017-10140- Updated
- 2026-11-02
EUVDEUVD-2017-1787 No score
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might allow local users to gain privileges by leveraging undocumented functionality in Berkeley DB 2.x and later, related to reading settings from DB_CONFIG in the current directory.
- Record
EUVD-2017-1787- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-698c-frxg-8qf9
7.8
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might...
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might allow local users to gain privileges by leveraging undocumented functionality in Berkeley DB 2.x and later, related to reading settings from DB_CONFIG in the current directory.
- Record
GHSA-698c-frxg-8qf9- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
7.8
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might allow local users to gain privileges by leveraging undocumented functionality in Berkeley DB 2.x and later, related to reading settings from DB_CONFIG in the current directory.
- Record
CVE-2017-10140- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-10140
7.8
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might allow local users to gain privileges by leveraging undocumented functionality in Berkeley DB 2.x and later, related to reading settings from DB_CONFIG in the current directory.
- Record
DEBIAN-CVE-2017-10140- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-10140
7.8
Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might allow local users to gain privileges by leveraging undocumented functionality in Berkeley DB 2.x and later, related to reading settings from DB_CONFIG in the current directory.
- Record
UBUNTU-CVE-2017-10140- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0380 No score
Updated db48 and db53 packages fix security vulnerability
It was found that Berkeley DB reads the DB_CONFIG configuration file from the current working directory by default. This happens when calling db_create() with dbenv=NULL; or using the dbm_open() function (CVE-2017-10140).
- Record
MGASA-2017-0380- Updated
- 2026-11-02
OSVUSN-3489-1 No score
db5.3 vulnerability
It was discovered that Berkeley DB incorrectly handled certain configuration files. An attacker could possibly use this issue to read sensitive information.
- Record
USN-3489-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
db5.3Debian:12 |
before 5.3.28-13.1 | 5.3.28-13.1 |
db5.3Debian:13 |
before 5.3.28-13.1 | 5.3.28-13.1 |
db5.3Debian:14 |
before 5.3.28-13.1 | 5.3.28-13.1 |
dbDebian:7 |
before 5.1.29-5+deb7u1, plus listed versions 5.1.29-5 |
5.1.29-5+deb7u1 |
db4.8Debian:7 |
before 4.8.30-12+deb7u1, plus listed versions 4.8.30-12 |
4.8.30-12+deb7u1 |
db4.7Debian:7 |
before 4.7.25-21+deb7u1, plus listed versions 4.7.25-21 |
4.7.25-21+deb7u1 |
db48Mageia:5 |
before 4.8.30-18.1.mga5 | 4.8.30-18.1.mga5 |
db53Mageia:5 |
before 5.3.28-4.1.mga5 | 5.3.28-4.1.mga5 |
db48Mageia:6 |
before 4.8.30-21.1.mga6 | 4.8.30-21.1.mga6 |
db53Mageia:6 |
before 5.3.28-10.1.mga6 | 5.3.28-10.1.mga6 |
db5.3Ubuntu:14.04:LTS |
before 5.3.28-3ubuntu3.1, plus listed versions 5.3.21-25.3.28-25.3.28-35.3.28-3ubuntu15.3.28-3ubuntu25.3.28-3ubuntu3 |
5.3.28-3ubuntu3.1 |
db5.3Ubuntu:16.04:LTS |
before 5.3.28-11ubuntu0.1, plus listed versions 5.3.28-11 |
5.3.28-11ubuntu0.1 |
db5.3Ubuntu:18.04:LTS |
before 5.3.28-13.1 | 5.3.28-13.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
seclists.org/oss-sec/2017/q3/285
access.redhat.com/errata/RHSA-2019:0366
oracle.com/security-alerts/cpujul2020.html
postfix.org/announcements/postfix-3.2.2.html
nvd.nist.gov/vuln/detail/CVE-2017-10140
github.com/advisories/GHSA-698c-frxg-8qf9
Show 9 moreShow less
security-tracker.debian.org/tracker/CVE-2017-10140
advisories.mageia.org/MGASA-2017-0380.html
bugs.mageia.org/show_bug.cgi?id=21203
openwall.com/lists/oss-security/2017/08/12/1
lists.fedoraproject.org/archives/list/[email protected]/thread/4JKFB2V7HP5V4KCYKSXMTWUDWUWQOV3S
ubuntu.com/security/CVE-2017-10140
ubuntu.com/security/notices/USN-3489-2
ubuntu.com/security/notices/USN-3489-1
cve.org/CVERecord?id=CVE-2017-10140