Every CVE Search/ Get API key

CVE-2017-10791

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0...

6.5 MediumFix available

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0.11.0. For example, a crash was observed within the library code when attempting to convert invalid SPSS data into CSV format. A crafted input will lead to a remote denial of service attack.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.63%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0.11.0. For example, a crash was observed within the library code when attempting to convert invalid SPSS data into CSV format. A crafted input will lead to a remote denial of service attack.

Record
CVE-2017-10791
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-190
Updated
2026-11-02
CVE List No score

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0.11.0. For example, a crash was observed within the library code when attempting to convert invalid SPSS data into CSV format. A crafted input will lead to a remote denial of service attack.

Record
CVE-2017-10791
Updated
2026-11-02
EUVDEUVD-2017-2436 No score

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0.11.0. For example, a crash was observed within the library code when attempting to convert invalid SPSS data into CSV format. A crafted input will lead to a remote denial of service attack.

Record
EUVD-2017-2436
Updated
2026-11-03
GitHub AdvisoriesGHSA-r93r-w7px-vcr6 6.5

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0...

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0.11.0. For example, a crash was observed within the library code when attempting to convert invalid SPSS data into CSV format. A crafted input will lead to a remote denial of service attack.

Record
GHSA-r93r-w7px-vcr6
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
OSV 6.5

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0.11.0. For example, a crash was observed within the library code when attempting to convert invalid SPSS data into CSV format. A crafted input will lead to a remote denial of service attack.

Record
CVE-2017-10791
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-10791 6.5

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0.11.0. For example, a crash was observed within the library code when attempting to convert invalid SPSS data into CSV format. A crafted input will lead to a remote denial of service attack.

Record
DEBIAN-CVE-2017-10791
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-10791 6.5

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0.11.0. For example, a crash was observed within the library code when attempting to convert invalid SPSS data into CSV format. A crafted input will lead to a remote denial of service attack.

Record
UBUNTU-CVE-2017-10791
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:11199-1 No score

pspp-1.4.1-2.3 on GA media

These are all security issues fixed in the pspp-1.4.1-2.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11199-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pspp
Debian:12
before 1.0.0-1
1.0.0-1
pspp
Debian:13
before 1.0.0-1
1.0.0-1
pspp
Debian:14
before 1.0.0-1
1.0.0-1
pspp
Ubuntu:16.04:LTS
All versions, plus listed versions
0.8.5-40.8.5-4build10.8.5-50.8.5-5build1
None known
pspp
openSUSE:Tumbleweed
From an advisory covering 7 CVEs
before 1.4.1-2.3
1.4.1-2.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-10791 is a medium vulnerability (CVSS 6.5) in Gnu Pspp, published July 2, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.63%, the 76th percentile. Fixed in pspp 1.0.0-1.

References

Show 8 moreShow less
MoveEnter Open