CVE-2017-11480
Denial of Service in Packetbeat
Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
- Record
CVE-2017-11480- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-404
- Updated
- 2026-11-02
CVE List No score
Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
- Record
CVE-2017-11480- Weakness
- CWE-404
- Updated
- 2026-11-02
EUVDEUVD-2022-0944 No score
Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
- Record
EUVD-2022-0944- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9q3g-m353-cp4p
7.5
Denial of Service in Packetbeat
Packetbeat versions prior to 5.6.4 and 6.0.0 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
- Record
GHSA-9q3g-m353-cp4p- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-404
- Updated
- 2026-11-02
OSV
7.5
Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
- Record
CVE-2017-11480- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-9q3g-m353-cp4p
7.5
Denial of Service in Packetbeat
Packetbeat versions prior to 5.6.4 and 6.0.0 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
- Record
GHSA-9q3g-m353-cp4p- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-404
- Updated
- 2026-11-02
OSVGO-2022-0643 No score
Denial of service in github.com/elastic/beats
A local attacker can cause a panic if they are able to send arbitrary traffic to a monitored port, due to an out of bounds read.
- Record
GO-2022-0643- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/elastic/beatsGo |
before 5.6.4 | 5.6.4 |
github.com/elastic/beatsGo |
6.0.0-alpha1 up to 6.0.0 | 6.0.0 |
github.com/elastic/beatsGo |
before 6.1.0+incompatible | 6.1.0+incompatible |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-11480 is a high vulnerability (CVSS 7.5) in Elastic Packetbeat, published December 8, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.44%, the 73rd percentile. Fixed in github.com/elastic/beats 5.6.4.
References
discuss.elastic.co/t/beats-5-6-4-security-update/106739
nvd.nist.gov/vuln/detail/CVE-2017-11480
github.com/elastic/beats/pull/5457
github.com/elastic/beats/pull/5479
github.com/elastic/beats/pull/5480
github.com/elastic/beats/commit/aeca65779d573976981587ca1d1461399e1b59dd
pkg.go.dev/vuln/GO-2022-0643
github.com/advisories/GHSA-9q3g-m353-cp4p
github.com/elastic/beats