CVE-2017-11664
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI 0.4.2 can cause a denial of...
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.
- Record
CVE-2017-11664- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.
- Record
CVE-2017-11664- Updated
- 2026-11-02
EUVDEUVD-2017-3276 No score
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.
- Record
EUVD-2017-3276- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4hv5-rh3v-rr4g
6.5
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI 0.4.2 can cause a denial of...
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.
- Record
GHSA-4hv5-rh3v-rr4g- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
6.5
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.
- Record
CVE-2017-11664- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-11664
6.5
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.
- Record
DEBIAN-CVE-2017-11664- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2017-11664
6.5
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI 0.4.2 can cause a denial of service (invalid memory read and application crash) via a crafted mid file.
- Record
UBUNTU-CVE-2017-11664- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0061 No score
Updated wildmidi packages fix security vulnerabilities
The _WM_SetupMidiEvent function in internal_midi.c:2318 in WildMIDI before 0.4.2 can cause a denial of service(invalid memory read and application crash) via a crafted mid file (CVE-2017-11661).
The _WM_ParseNewMidi function in f_midi.c in WildMIDI before 0.4.2 can cause a denial of service(invalid memory read and application crash) via a crafted mid file (CVE-2017-11662).
The _WM_SetupMidiEvent function in internal_midi.c:2315 in WildMIDI before 0.4.2 can cause a denial of service(invalid memory read and application crash) via a crafted mid file (CVE-2017-11663).
The _WM_SetupMidiEvent function in internal_midi.c:2122 in WildMIDI before 0.4.2 can cause a denial of service(invalid memory read and application crash) via a crafted mid file (CVE-2017-11664).
- Record
MGASA-2018-0061- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11512-1 No score
libWildMidi2-0.4.4-1.3 on GA media
These are all security issues fixed in the libWildMidi2-0.4.4-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11512-1- Updated
- 2026-11-02
OSVUSN-4807-1 No score
wildmidi vulnerabilities
It was discovered that WildMIDI incorrectly handled certain MID files. A remote attacker could possibly use this issue to cause a denial of service.
- Record
USN-4807-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wildmidiDebian:12 |
before 0.4.2-1 | 0.4.2-1 |
wildmidiDebian:13 |
before 0.4.2-1 | 0.4.2-1 |
wildmidiDebian:14 |
before 0.4.2-1 | 0.4.2-1 |
wildmidiMageia:6 From an advisory covering 4 CVEs |
before 0.4.2-1.mga6 | 0.4.2-1.mga6 |
wildmidiUbuntu:14.04:LTS |
All versions, plus listed versions 0.2.3.4-2.1ubuntu20.2.3.4-2.1ubuntu3 |
None known |
wildmidiUbuntu:Pro:16.04:LTS |
before 0.3.8-2ubuntu0.1~esm1, plus listed versions 0.3.8-2 |
0.3.8-2ubuntu0.1~esm1 |
wildmidiUbuntu:Pro:16.04:LTS From an advisory covering 4 CVEs |
before 0.3.8-2ubuntu0.1~esm1, plus listed versions 0.3.8-2 |
0.3.8-2ubuntu0.1~esm1 |
wildmidiopenSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 0.4.4-1.3 | 0.4.4-1.3 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | WildMIDI 0.4.2 - Multiple Vulnerabilities | 2017-08-08 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-11664 is a medium vulnerability (CVSS 6.5) in Mindwerks Wildmidi, published August 17, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 8.50%, the 95th percentile. Fixed in wildmidi 0.4.2-1.
References
exploit-db.com/exploits/42433
seclists.org/fulldisclosure/2017/Aug/12
github.com/Mindwerks/wildmidi/commit/ad6d7cf88d6673167ca1f517248af9409a9f1be1
nvd.nist.gov/vuln/detail/CVE-2017-11664
github.com/advisories/GHSA-4hv5-rh3v-rr4g
security-tracker.debian.org/tracker/CVE-2017-11664
Show 12 moreShow less
advisories.mageia.org/MGASA-2018-0061.html
bugs.mageia.org/show_bug.cgi?id=22200
lists.fedoraproject.org/archives/list/[email protected]/thread/XGAZHDTXXL3RFRCNGE4XLOHD4MASNLBB
ubuntu.com/security/CVE-2017-11664
github.com/Mindwerks/wildmidi/commit/660b513d99bced8783a4a5984ac2f742c74ebbdd
ubuntu.com/security/notices/USN-4807-1
cve.org/CVERecord?id=CVE-2017-11664
ubuntu.com/security/CVE-2017-11661
ubuntu.com/security/CVE-2017-11662
ubuntu.com/security/CVE-2017-11663
suse.com/security/cve/CVE-2017-11661
suse.com/security/cve/CVE-2017-11664