CVE-2017-12142
In ytnef 1.9.2, an invalid memory read vulnerability was found in the function SwapDWord in ytnef...
In ytnef 1.9.2, an invalid memory read vulnerability was found in the function SwapDWord in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
In ytnef 1.9.2, an invalid memory read vulnerability was found in the function SwapDWord in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
CVE-2017-12142- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
In ytnef 1.9.2, an invalid memory read vulnerability was found in the function SwapDWord in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
CVE-2017-12142- Updated
- 2026-11-02
EUVDEUVD-2017-3726 No score
In ytnef 1.9.2, an invalid memory read vulnerability was found in the function SwapDWord in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
EUVD-2017-3726- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wx58-mfwq-x7r3
5.5
In ytnef 1.9.2, an invalid memory read vulnerability was found in the function SwapDWord in ytnef...
In ytnef 1.9.2, an invalid memory read vulnerability was found in the function SwapDWord in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
GHSA-wx58-mfwq-x7r3- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
5.5
In ytnef 1.9.2, an invalid memory read vulnerability was found in the function SwapDWord in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
CVE-2017-12142- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-12142
5.5
In ytnef 1.9.2, an invalid memory read vulnerability was found in the function SwapDWord in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
DEBIAN-CVE-2017-12142- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-12142
5.5
In ytnef 1.9.2, an invalid memory read vulnerability was found in the function SwapDWord in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
UBUNTU-CVE-2017-12142- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libytnefDebian:12 |
before 1.9.3-1 | 1.9.3-1 |
libytnefDebian:13 |
before 1.9.3-1 | 1.9.3-1 |
libytnefDebian:14 |
before 1.9.3-1 | 1.9.3-1 |
libytnefUbuntu:16.04:LTS |
All versions, plus listed versions 1.5-61.5-91.5-9ubuntu0.1 |
None known |
libytnefUbuntu:18.04:LTS |
All versions, plus listed versions 1.9.2-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-12142 is a medium vulnerability (CVSS 5.5) in Ytnef Project Ytnef, published August 2, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.97%, the 61st percentile. Fixed in libytnef 1.9.3-1.
References
github.com/Yeraze/ytnef/issues/49
somevulnsofadlab.blogspot.com/2017/07/ytnefinvalid-memory-read-in-swapdword.html
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LFJWMUEUC4ILH2HEOCYVVLQT654ZMCGQ
nvd.nist.gov/vuln/detail/CVE-2017-12142
lists.fedoraproject.org/archives/list/[email protected]/message/LFJWMUEUC4ILH2HEOCYVVLQT654ZMCGQ
github.com/advisories/GHSA-wx58-mfwq-x7r3
security-tracker.debian.org/tracker/CVE-2017-12142
ubuntu.com/security/CVE-2017-12142
cve.org/CVERecord?id=CVE-2017-12142