Every CVE Search/ Get API key

CVE-2017-12157

Moodle sensitive information disclosure

4.3 MediumFix available

In Moodle 3.x, various course reports allow teachers to view details about users in the groups they can't access.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

1.10%Up 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 4.3

In Moodle 3.x, various course reports allow teachers to view details about users in the groups they can't access.

Record
CVE-2017-12157
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

In Moodle 3.x, various course reports allow teachers to view details about users in the groups they can't access.

Record
CVE-2017-12157
Updated
2026-11-02
EUVDEUVD-2022-4025 No score

In Moodle 3.x, various course reports allow teachers to view details about users in the groups they can't access.

Record
EUVD-2022-4025
Updated
2026-11-03
GitHub AdvisoriesGHSA-gw95-48xq-gqf9 4.3

Moodle sensitive information disclosure

In Moodle 3.x, various course reports allow teachers to view details about users in the groups they can't access.

Record
GHSA-gw95-48xq-gqf9
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 4.3

In Moodle 3.x, various course reports allow teachers to view details about users in the groups they can't access.

Record
CVE-2017-12157
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVGHSA-gw95-48xq-gqf9 4.3

Moodle sensitive information disclosure

In Moodle 3.x, various course reports allow teachers to view details about users in the groups they can't access.

Record
GHSA-gw95-48xq-gqf9
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSVUBUNTU-CVE-2017-12157 4.3

In Moodle 3.x, various course reports allow teachers to view details about users in the groups they can't access.

Record
UBUNTU-CVE-2017-12157
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
3.3.0 to 3.3.1
3.3.2
moodle/moodle
Packagist
3.2.0 to 3.2.4
3.2.5
moodle/moodle
Packagist
through 3.1.7
3.1.8
moodle/moodle
Packagist
3.3.0 up to 3.3.2, plus listed versions
v3.3.0v3.3.1
3.3.2
moodle/moodle
Packagist
3.2.0 up to 3.2.5, plus listed versions
v3.2.0v3.2.1v3.2.2v3.2.3v3.2.4
3.2.5
moodle/moodle
Packagist
before 3.1.8, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
3.1.8
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-12157 is a medium vulnerability (CVSS 4.3) in Moodle, published September 18, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.10%, the 65th percentile. Fixed in moodle/moodle 3.3.2.

References

This page doesn't list everything

Left out here: 77 versions. The JSON record has them.

MoveEnter Open