Every CVE Search/ Get API key

CVE-2017-12433

In ImageMagick 7.0.6-1, a memory leak vulnerability was found in the function ReadPESImage in...

6.5 MediumFix available

In ImageMagick 7.0.6-1, a memory leak vulnerability was found in the function ReadPESImage in coders/pes.c, which allows attackers to cause a denial of service, related to ResizeMagickMemory in memory.c.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.28%Up 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

In ImageMagick 7.0.6-1, a memory leak vulnerability was found in the function ReadPESImage in coders/pes.c, which allows attackers to cause a denial of service, related to ResizeMagickMemory in memory.c.

Record
CVE-2017-12433
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-772
Updated
2026-11-02
CVE List No score

In ImageMagick 7.0.6-1, a memory leak vulnerability was found in the function ReadPESImage in coders/pes.c, which allows attackers to cause a denial of service, related to ResizeMagickMemory in memory.c.

Record
CVE-2017-12433
Updated
2026-11-02
EUVDEUVD-2017-4006 No score

In ImageMagick 7.0.6-1, a memory leak vulnerability was found in the function ReadPESImage in coders/pes.c, which allows attackers to cause a denial of service, related to ResizeMagickMemory in memory.c.

Record
EUVD-2017-4006
Updated
2026-11-03
GitHub AdvisoriesGHSA-fqv8-75p6-w8vc 6.5

In ImageMagick 7.0.6-1, a memory leak vulnerability was found in the function ReadPESImage in...

In ImageMagick 7.0.6-1, a memory leak vulnerability was found in the function ReadPESImage in coders/pes.c, which allows attackers to cause a denial of service, related to ResizeMagickMemory in memory.c.

Record
GHSA-fqv8-75p6-w8vc
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-772
Updated
2026-11-02
OSV 6.5

In ImageMagick 7.0.6-1, a memory leak vulnerability was found in the function ReadPESImage in coders/pes.c, which allows attackers to cause a denial of service, related to ResizeMagickMemory in memory.c.

Record
CVE-2017-12433
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-12433 6.5

In ImageMagick 7.0.6-1, a memory leak vulnerability was found in the function ReadPESImage in coders/pes.c, which allows attackers to cause a denial of service, related to ResizeMagickMemory in memory.c.

Record
DEBIAN-CVE-2017-12433
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-12433 6.5

In ImageMagick 7.0.6-1, a memory leak vulnerability was found in the function ReadPESImage in coders/pes.c, which allows attackers to cause a denial of service, related to ResizeMagickMemory in memory.c.

Record
UBUNTU-CVE-2017-12433
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVSUSE-SU-2017:2949-1 No score

Security update for ImageMagick

This update for ImageMagick fixes the following issues:

Security issues fixed:

  • CVE-2017-15033: A denial of service attack (memory leak) was fixed in ReadYUVImage in coders/yuv.c [bsc#1061873]
  • CVE-2017-11446: An infinite loop in ReadPESImage was fixed. (bsc#1049379)
  • CVE-2017-12433: A memory leak in ReadPESImage in coders/pes.c was fixed. (bsc#1052545)
  • CVE-2017-12428: A memory leak in ReadWMFImage in coders/wmf.c was fixed. (bsc#1052249)
  • CVE-2017-12431: A use-after-free in ReadWMFImage was fixed. (bsc#1052253)
  • CVE-2017-11534: A memory leak in the lite_font_map() in coders/wmf.c was fixed. (bsc#1050135)
  • CVE-2017-13133: A memory exhaustion in load_level function in coders/xcf.c was fixed. (bsc#1055219)
  • CVE-2017-13139: A out-of-bounds read in the ReadOneMNGImage was fixed. (bsc#1055430)

This update also reverts an incorrect fix for CVE-2016-7530 [bsc#1054924].

Record
SUSE-SU-2017:2949-1
Updated
2026-11-02
OSVUSN-3681-1 No score

imagemagick vulnerabilities

It was discovered that ImageMagick incorrectly handled certain malformed image files. If a user or automated system using ImageMagick were tricked into opening a specially crafted image, an attacker could exploit this to cause a denial of service or possibly execute code with the privileges of the user invoking the program.

Record
USN-3681-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
imagemagick
Debian:12
before 8:6.9.9.34+dfsg-3
8:6.9.9.34+dfsg-3
imagemagick
Debian:13
before 8:6.9.9.34+dfsg-3
8:6.9.9.34+dfsg-3
imagemagick
Debian:14
before 8:6.9.9.34+dfsg-3
8:6.9.9.34+dfsg-3
imagemagick
Debian:7
before 8:6.7.7.10-5+deb7u16, plus listed versions
8:6.7.7.10-58:6.7.7.10-5+deb7u108:6.7.7.10-5+deb7u118:6.7.7.10-5+deb7u128:6.7.7.10-5+deb7u13
Show 10 moreShow less
8:6.7.7.10-5+deb7u148:6.7.7.10-5+deb7u158:6.7.7.10-5+deb7u28:6.7.7.10-5+deb7u38:6.7.7.10-5+deb7u48:6.7.7.10-5+deb7u58:6.7.7.10-5+deb7u68:6.7.7.10-5+deb7u78:6.7.7.10-5+deb7u88:6.7.7.10-5+deb7u9
8:6.7.7.10-5+deb7u16
ImageMagick
SUSE:Linux Enterprise Desktop 12 SP2
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
ImageMagick
SUSE:Linux Enterprise Desktop 12 SP3
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
ImageMagick
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
ImageMagick
SUSE:Linux Enterprise Software Development Kit 12 SP2
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
ImageMagick
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
ImageMagick
SUSE:Linux Enterprise Server 12 SP2
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
Show 8 moreShow less
Affected packages
PackageAffectedFixed
ImageMagick
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
ImageMagick
SUSE:Linux Enterprise Server 12 SP3
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
ImageMagick
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
ImageMagick
SUSE:Linux Enterprise Workstation Extension 12 SP2
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
ImageMagick
SUSE:Linux Enterprise Workstation Extension 12 SP3
before 6.8.8.1-71.12.1
6.8.8.1-71.12.1
imagemagick
Ubuntu:14.04:LTS
before 8:6.7.7.10-6ubuntu3.11, plus listed versions
8:6.7.7.10-5ubuntu38:6.7.7.10-5ubuntu48:6.7.7.10-6ubuntu18:6.7.7.10-6ubuntu28:6.7.7.10-6ubuntu3
Show 9 moreShow less
8:6.7.7.10-6ubuntu3.18:6.7.7.10-6ubuntu3.28:6.7.7.10-6ubuntu3.38:6.7.7.10-6ubuntu3.48:6.7.7.10-6ubuntu3.58:6.7.7.10-6ubuntu3.68:6.7.7.10-6ubuntu3.78:6.7.7.10-6ubuntu3.88:6.7.7.10-6ubuntu3.9
8:6.7.7.10-6ubuntu3.11
imagemagick
Ubuntu:16.04:LTS
before 8:6.8.9.9-7ubuntu5.11, plus listed versions
8:6.8.9.9-5ubuntu28:6.8.9.9-68:6.8.9.9-6build18:6.8.9.9-78:6.8.9.9-7ubuntu1
Show 13 moreShow less
8:6.8.9.9-7ubuntu28:6.8.9.9-7ubuntu38:6.8.9.9-7ubuntu48:6.8.9.9-7ubuntu58:6.8.9.9-7ubuntu5.18:6.8.9.9-7ubuntu5.28:6.8.9.9-7ubuntu5.38:6.8.9.9-7ubuntu5.48:6.8.9.9-7ubuntu5.58:6.8.9.9-7ubuntu5.68:6.8.9.9-7ubuntu5.78:6.8.9.9-7ubuntu5.88:6.8.9.9-7ubuntu5.9
8:6.8.9.9-7ubuntu5.11
imagemagick
Ubuntu:18.04:LTS
before 8:6.9.7.4+dfsg-16ubuntu6.2, plus listed versions
8:6.9.7.4+dfsg-16ubuntu28:6.9.7.4+dfsg-16ubuntu38:6.9.7.4+dfsg-16ubuntu48:6.9.7.4+dfsg-16ubuntu58:6.9.7.4+dfsg-16ubuntu6
8:6.9.7.4+dfsg-16ubuntu6.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-12433 is a medium vulnerability (CVSS 6.5) in Imagemagick, published August 4, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.28%, the 70th percentile. Fixed in imagemagick 8:6.9.9.34+dfsg-3.

References

Show 144 moreShow less
MoveEnter Open