Every CVE Search/ Get API key

CVE-2017-12865

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers...

9.8 CriticalPublic exploitFix available

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted response query string passed to the "name" variable.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

5.52%Up 1.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted response query string passed to the "name" variable.

Record
CVE-2017-12865
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted response query string passed to the "name" variable.

Record
CVE-2017-12865
Updated
2026-11-02
EUVDEUVD-2017-4397 No score

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted response query string passed to the "name" variable.

Record
EUVD-2017-4397
Updated
2026-11-03
GitHub AdvisoriesGHSA-2f42-jv77-x675 9.8

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers...

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted response query string passed to the "name" variable.

Record
GHSA-2f42-jv77-x675
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 9.8

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted response query string passed to the "name" variable.

Record
CVE-2017-12865
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-12865 9.8

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted response query string passed to the "name" variable.

Record
DEBIAN-CVE-2017-12865
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-12865 9.8

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted response query string passed to the "name" variable.

Record
UBUNTU-CVE-2017-12865
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0036 No score

Updated connman packages fix security vulnerability

Security consultants in NRI Secure Technologies discovered a stack overflow vulnerability in ConnMan. An attacker with control of the DNS responses to the DNS proxy in ConnMan might crash the service and, in same cases, remotely execute arbitrary commands in the host running the service (CVE-2017-12865)

Record
MGASA-2018-0036
Updated
2026-11-02
OSVopenSUSE-SU-2024:10692-1 No score

connman-1.40-2.2 on GA media

These are all security issues fixed in the connman-1.40-2.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10692-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
connman
Debian:12
before 1.35-1
1.35-1
connman
Debian:13
before 1.35-1
1.35-1
connman
Debian:14
before 1.35-1
1.35-1
connman
Debian:7
before 1.0-1.1+wheezy2, plus listed versions
1.0-1.1+wheezy1
1.0-1.1+wheezy2
connman
Debian:8
before 1.21-1.2+deb8u1, plus listed versions
1.21-1.2
1.21-1.2+deb8u1
connman
Debian:9
before 1.33-3+deb9u1, plus listed versions
1.33-3
1.33-3+deb9u1
connman
Mageia:5
before 1.24-4.1.mga5
1.24-4.1.mga5
connman
Mageia:6
before 1.33-6.1.mga6
1.33-6.1.mga6
connman
Ubuntu:16.04:LTS
before 1.21-1.2+deb8u1build0.16.04.1, plus listed versions
1.21-1.21.21-1.2build11.21-1.2build2
1.21-1.2+deb8u1build0.16.04.1
connman
openSUSE:Tumbleweed
before 1.40-2.2
1.40-2.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubManaswiJaiswal/Reproducing-ConnMan-1.342025-09-10

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-12865 is a critical vulnerability (CVSS 9.8) in Intel Connman, published August 27, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 5.52%, the 92nd percentile. Fixed in connman 1.35-1.

References

Show 12 moreShow less
MoveEnter Open