CVE-2017-12867
SimpleSAMLphp Invalid token creation and validation
The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.9
The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
- Record
CVE-2017-12867- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-613
- Updated
- 2026-11-02
CVE List No score
The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
- Record
CVE-2017-12867- Updated
- 2026-11-02
EUVDEUVD-2022-2546 No score
The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
- Record
EUVD-2022-2546- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-597c-mh7m-48v7
5.9
SimpleSAMLphp Invalid token creation and validation
The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
- Record
GHSA-597c-mh7m-48v7- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-613
- Updated
- 2026-11-02
OSV
5.9
The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
- Record
CVE-2017-12867- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-12867
5.9
The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
- Record
DEBIAN-CVE-2017-12867- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-597c-mh7m-48v7
5.9
SimpleSAMLphp Invalid token creation and validation
The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
- Record
GHSA-597c-mh7m-48v7- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-613
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-12867
5.9
The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
- Record
UBUNTU-CVE-2017-12867- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
simplesamlphp/simplesamlphpPackagist |
1.14.0 up to 1.14.15 | 1.14.15 |
simplesamlphpDebian:12 |
before 1.14.15-1 | 1.14.15-1 |
simplesamlphpDebian:14 |
before 1.14.15-1, plus listed versions 1.10.0-11.11.0-11.12.0-11.12.0~rc1-11.12.0~rc2-1 Show 33 moreShow less1.13.0-11.13.1-11.13.1-21.13.2-11.14.0-11.14.1-11.14.10-11.14.11-11.14.2-11.14.2-21.14.3-11.14.4-11.14.5-11.14.6-11.14.7-11.14.8-11.14.9-11.6.0-11.6.1-11.6.2-11.6.3-11.6.3-21.6.3-31.7.0-11.7.0-21.8.0-11.8.1-11.8.2-11.9.0-11.9.0~rc1-11.9.0~rc2-11.9.1-11.9.2-1 |
1.14.15-1 |
simplesamlphpDebian:7 |
before 1.9.2-1+deb7u1, plus listed versions 1.9.2-1 |
1.9.2-1+deb7u1 |
simplesamlphpDebian:8 |
before 1.13.1-2+deb8u1, plus listed versions 1.13.1-2 |
1.13.1-2+deb8u1 |
simplesamlphpDebian:9 |
before 1.14.11-1+deb9u1, plus listed versions 1.14.11-1 |
1.14.11-1+deb9u1 |
simplesamlphp/simplesamlphpPackagist |
1.14.0 up to 1.14.15, plus listed versions v1.14.0v1.14.1v1.14.10v1.14.11v1.14.12 Show 10 moreShow lessv1.14.13v1.14.14v1.14.2v1.14.3v1.14.4v1.14.5v1.14.6v1.14.7v1.14.8v1.14.9 |
1.14.15 |
simplesamlphpUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.13.2-11.14.0-11.14.0-1ubuntu21.14.0-1ubuntu2+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-12867 is a medium vulnerability (CVSS 5.9) in Simplesamlphp, published August 29, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.25%, the 69th percentile. Fixed in simplesamlphp/simplesamlphp 1.14.15.
References
lists.debian.org/debian-lts-announce/2017/12/msg00007.html
debian.org/security/2018/dsa-4127
simplesamlphp.org/security/201708-01
nvd.nist.gov/vuln/detail/CVE-2017-12867
github.com/simplesamlphp/simplesamlphp/commit/608f24c2d5afd70c2af050785d2b12f878b33c68
github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/simplesamlphp/CVE-2017-12867.yaml