CVE-2017-12904
Improper Neutralization of Special Elements used in an OS Command in bookmarking function of...
Improper Neutralization of Special Elements used in an OS Command in bookmarking function of Newsbeuter versions 0.7 through 2.9 allows remote attackers to perform user-assisted code execution by crafting an RSS item that includes shell code in its title and/or URL.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Improper Neutralization of Special Elements used in an OS Command in bookmarking function of Newsbeuter versions 0.7 through 2.9 allows remote attackers to perform user-assisted code execution by crafting an RSS item that includes shell code in its title and/or URL.
- Record
CVE-2017-12904- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-943
- Updated
- 2026-11-02
CVE List No score
Improper Neutralization of Special Elements used in an OS Command in bookmarking function of Newsbeuter versions 0.7 through 2.9 allows remote attackers to perform user-assisted code execution by crafting an RSS item that includes shell code in its title and/or URL.
- Record
CVE-2017-12904- Updated
- 2026-11-02
EUVDEUVD-2017-4428 No score
Improper Neutralization of Special Elements used in an OS Command in bookmarking function of Newsbeuter versions 0.7 through 2.9 allows remote attackers to perform user-assisted code execution by crafting an RSS item that includes shell code in its title and/or URL.
- Record
EUVD-2017-4428- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rc2j-xvrx-6gqj
8.8
Improper Neutralization of Special Elements used in an OS Command in bookmarking function of...
Improper Neutralization of Special Elements used in an OS Command in bookmarking function of Newsbeuter versions 0.7 through 2.9 allows remote attackers to perform user-assisted code execution by crafting an RSS item that includes shell code in its title and/or URL.
- Record
GHSA-rc2j-xvrx-6gqj- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-943
- Updated
- 2026-11-02
OSVALPINE-CVE-2017-12904
8.8
Improper Neutralization of Special Elements used in an OS Command in bookmarking function of Newsbeuter versions 0.7 through 2.9 allows remote attackers to perform user-assisted code execution by crafting an RSS item that includes shell code in its title and/or URL.
- Record
ALPINE-CVE-2017-12904- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
8.8
Improper Neutralization of Special Elements used in an OS Command in bookmarking function of Newsbeuter versions 0.7 through 2.9 allows remote attackers to perform user-assisted code execution by crafting an RSS item that includes shell code in its title and/or URL.
- Record
CVE-2017-12904- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-12904
8.8
Improper Neutralization of Special Elements used in an OS Command in bookmarking function of Newsbeuter versions 0.7 through 2.9 allows remote attackers to perform user-assisted code execution by crafting an RSS item that includes shell code in its title and/or URL.
- Record
UBUNTU-CVE-2017-12904- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4585-1 No score
newsbeuter vulnerabilities
It was discovered that Newsbeuter didn't handle the command line input properly. An remote attacker could use it to ran remote code by crafting a special input file. (CVE-2017-12904)
It was discovered that Newsbeuter didn't handle metacharacters in its filename properly. An remote attacker could use it to ran remote code by crafting a special filename. (CVE-2017-14500)
- Record
USN-4585-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
newsbeuterAlpine:v3.3 |
before 2.9-r4 | 2.9-r4 |
newsbeuterAlpine:v3.4 |
before 2.9-r4 | 2.9-r4 |
newsbeuterAlpine:v3.5 |
before 2.9-r4 | 2.9-r4 |
newsbeuterAlpine:v3.6 |
before 2.9-r4 | 2.9-r4 |
newsbeuterAlpine:v3.7 |
before 2.9-r4 | 2.9-r4 |
newsbeuterDebian:7 |
before 2.5-2+deb7u2, plus listed versions 2.5-22.5-2+deb7u1 |
2.5-2+deb7u2 |
newsbeuterDebian:8 |
before 2.8-2+deb8u1, plus listed versions 2.8-2 |
2.8-2+deb8u1 |
newsbeuterDebian:9 |
before 2.9-5+deb9u1, plus listed versions 2.9-5 |
2.9-5+deb9u1 |
newsbeuterUbuntu:16.04:LTS |
before 2.9-3ubuntu0.1, plus listed versions 2.8-22.9-0ubuntu12.9-3 |
2.9-3ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-12904 is a high vulnerability (CVSS 8.8) in Newsbeuter, published August 18, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.40%, the 93rd percentile. Fixed in newsbeuter 2.9-r4.