Every CVE Search/ Get API key

CVE-2017-12927

A cross-site scripting vulnerability exists in Cacti 1.1.17 in the method parameter in spikekill...

6.1 MediumFix available

A cross-site scripting vulnerability exists in Cacti 1.1.17 in the method parameter in spikekill.php.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.37%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

A cross-site scripting vulnerability exists in Cacti 1.1.17 in the method parameter in spikekill.php.

Record
CVE-2017-12927
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

A cross-site scripting vulnerability exists in Cacti 1.1.17 in the method parameter in spikekill.php.

Record
CVE-2017-12927
Updated
2026-11-02
EUVDEUVD-2017-4451 No score

A cross-site scripting vulnerability exists in Cacti 1.1.17 in the method parameter in spikekill.php.

Record
EUVD-2017-4451
Updated
2026-11-03
GitHub AdvisoriesGHSA-w66g-pq85-j4vq 6.1

A cross-site scripting vulnerability exists in Cacti 1.1.17 in the method parameter in spikekill...

A cross-site scripting vulnerability exists in Cacti 1.1.17 in the method parameter in spikekill.php.

Record
GHSA-w66g-pq85-j4vq
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

A cross-site scripting vulnerability exists in Cacti 1.1.17 in the method parameter in spikekill.php.

Record
CVE-2017-12927
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2017-12927 6.1

A cross-site scripting vulnerability exists in Cacti 1.1.17 in the method parameter in spikekill.php.

Record
DEBIAN-CVE-2017-12927
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2017-12927 6.1

A cross-site scripting vulnerability exists in Cacti 1.1.17 in the method parameter in spikekill.php.

Record
UBUNTU-CVE-2017-12927
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2024:10670-1 No score

cacti-1.2.18-1.2 on GA media

These are all security issues fixed in the cacti-1.2.18-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10670-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cacti
Debian:12
before 1.1.17+ds1-2
1.1.17+ds1-2
cacti
Debian:13
before 1.1.17+ds1-2
1.1.17+ds1-2
cacti
Debian:14
before 1.1.17+ds1-2
1.1.17+ds1-2
cacti
openSUSE:Tumbleweed
before 1.2.18-1.2
1.2.18-1.2

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-12927 is a medium vulnerability (CVSS 6.1) in Cacti, published August 18, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.37%, the 72nd percentile. Fixed in cacti 1.1.17+ds1-2.

References

Show 34 moreShow less
MoveEnter Open