Every CVE Search/ Get API key

CVE-2017-14107

The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which...

6.5 MediumFix available

The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.23%Up 2.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive.

Record
CVE-2017-14107
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-770
Updated
2026-11-02
CVE List No score

The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive.

Record
CVE-2017-14107
Updated
2026-11-02
EUVDEUVD-2017-5619 No score

The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive.

Record
EUVD-2017-5619
Updated
2026-11-03
GitHub AdvisoriesGHSA-r7fp-6p6g-f7f5 6.5

The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which...

The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive.

Record
GHSA-r7fp-6p6g-f7f5
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-770
Updated
2026-11-02
OSVBELL-CVE-2017-14107 6.5

CVE-2017-14107 does not affect BellSoft software

Record
BELL-CVE-2017-14107
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 6.5

The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive.

Record
CVE-2017-14107
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2017-14107 6.5

The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive.

Record
DEBIAN-CVE-2017-14107
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-14107 6.5

The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive.

Record
UBUNTU-CVE-2017-14107
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0020 No score

Updated libzip packages fix security vulnerability

The _zip_read_eocd64 function mishandled EOCD records, which allowed remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive (CVE-2017-14107).

Record
MGASA-2018-0020
Updated
2026-11-02
OSVopenSUSE-SU-2024:11018-1 No score

libzip-devel-1.8.0-1.2 on GA media

These are all security issues fixed in the libzip-devel-1.8.0-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11018-1
Updated
2026-11-02
OSVSUSE-SU-2017:2546-1 No score

Security update for libzip

This update for libzip fixes one issues.

This security issue was fixed:

  • CVE-2017-14107: The _zip_read_eocd64 function mishandled EOCD records, which allowed remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive (bsc#1056996).
Record
SUSE-SU-2017:2546-1
Updated
2026-11-02
OSVUSN-4811-1 No score

libzip vulnerability

It was discovered that libzip mishandled certain malformed ZIP archives. A remote attacker could use this vulnerability to cause a denial of service.

Record
USN-4811-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libzip
Debian:12
before 1.5.1-3
1.5.1-3
libzip
Debian:13
before 1.5.1-3
1.5.1-3
libzip
Debian:14
before 1.5.1-3
1.5.1-3
libzip
Debian:9
before 1.1.2-1.1+deb9u1, plus listed versions
1.1.2-1.1
1.1.2-1.1+deb9u1
libzip
Mageia:5
before 0.11.2-4.1.mga5
0.11.2-4.1.mga5
libzip
Mageia:6
before 1.1.3-1.1.mga6
1.1.3-1.1.mga6
libzip
SUSE:Linux Enterprise Desktop 12 SP2
before 0.11.1-13.3.1
0.11.1-13.3.1
libzip
SUSE:Linux Enterprise Desktop 12 SP3
before 0.11.1-13.3.1
0.11.1-13.3.1
libzip
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
before 0.11.1-13.3.1
0.11.1-13.3.1
libzip
SUSE:Linux Enterprise Software Development Kit 12 SP2
before 0.11.1-13.3.1
0.11.1-13.3.1
Show 8 moreShow less
Affected packages
PackageAffectedFixed
libzip
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 0.11.1-13.3.1
0.11.1-13.3.1
libzip
SUSE:Linux Enterprise Server 12 SP2
before 0.11.1-13.3.1
0.11.1-13.3.1
libzip
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 0.11.1-13.3.1
0.11.1-13.3.1
libzip
SUSE:Linux Enterprise Server 12 SP3
before 0.11.1-13.3.1
0.11.1-13.3.1
libzip
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 0.11.1-13.3.1
0.11.1-13.3.1
libzip
Ubuntu:Pro:16.04:LTS
before 1.0.1-0ubuntu1.1~esm1, plus listed versions
1.0.1-0ubuntu1
1.0.1-0ubuntu1.1~esm1
libzip
Ubuntu:Pro:18.04:LTS
before 1.1.2-1.1ubuntu0.1~esm1, plus listed versions
1.1.2-1.1
1.1.2-1.1ubuntu0.1~esm1
libzip
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 1.8.0-1.2
1.8.0-1.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-14107 is a medium vulnerability (CVSS 6.5) in Libzip, published September 1, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.23%, the 88th percentile. Fixed in libzip 1.5.1-3.

References

Show 11 moreShow less
MoveEnter Open