Every CVE Search/ Get API key

CVE-2017-14431

Memory leak in Xen 3.3 through 4.8.x allows guest OS users to cause a denial of service (ARM or...

5.5 MediumFix available

Memory leak in Xen 3.3 through 4.8.x allows guest OS users to cause a denial of service (ARM or x86 AMD host OS memory consumption) by continually rebooting, because certain cleanup is skipped if no pass-through device was ever assigned, aka XSA-207.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.34%Down 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

Memory leak in Xen 3.3 through 4.8.x allows guest OS users to cause a denial of service (ARM or x86 AMD host OS memory consumption) by continually rebooting, because certain cleanup is skipped if no pass-through device was ever assigned, aka XSA-207.

Record
CVE-2017-14431
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
4.9 MediumAV:L/AC:L/Au:N/C:N/I:N/A:C
Weakness
CWE-772
Updated
2026-11-02
CVE List No score

Memory leak in Xen 3.3 through 4.8.x allows guest OS users to cause a denial of service (ARM or x86 AMD host OS memory consumption) by continually rebooting, because certain cleanup is skipped if no pass-through device was ever assigned, aka XSA-207.

Record
CVE-2017-14431
Updated
2026-11-02
EUVDEUVD-2017-5934 No score

Memory leak in Xen 3.3 through 4.8.x allows guest OS users to cause a denial of service (ARM or x86 AMD host OS memory consumption) by continually rebooting, because certain cleanup is skipped if no pass-through device was ever assigned, aka XSA-207.

Record
EUVD-2017-5934
Updated
2026-11-03
GitHub AdvisoriesGHSA-5c92-xf29-3c94 5.5

Memory leak in Xen 3.3 through 4.8.x allows guest OS users to cause a denial of service (ARM or...

Memory leak in Xen 3.3 through 4.8.x allows guest OS users to cause a denial of service (ARM or x86 AMD host OS memory consumption) by continually rebooting, because certain cleanup is skipped if no pass-through device was ever assigned, aka XSA-207.

Record
GHSA-5c92-xf29-3c94
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-772
Updated
2026-11-02
OSV 5.5

Memory leak in Xen 3.3 through 4.8.x allows guest OS users to cause a denial of service (ARM or x86 AMD host OS memory consumption) by continually rebooting, because certain cleanup is skipped if no pass-through device was ever assigned, aka XSA-207.

Record
CVE-2017-14431
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-14431 5.5

Memory leak in Xen 3.3 through 4.8.x allows guest OS users to cause a denial of service (ARM or x86 AMD host OS memory consumption) by continually rebooting, because certain cleanup is skipped if no pass-through device was ever assigned, aka XSA-207.

Record
DEBIAN-CVE-2017-14431
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-14431 5.5

Memory leak in Xen 3.3 through 4.8.x allows guest OS users to cause a denial of service (ARM or x86 AMD host OS memory consumption) by continually rebooting, because certain cleanup is skipped if no pass-through device was ever assigned, aka XSA-207.

Record
UBUNTU-CVE-2017-14431
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xen
Debian:12
before 4.8.1-1
4.8.1-1
xen
Debian:13
before 4.8.1-1
4.8.1-1
xen
Debian:14
before 4.8.1-1
4.8.1-1
xen
Debian:8
From an advisory covering 2 CVEs
before 4.4.4lts1-0+deb8u1, plus listed versions
4.4.1-94.4.1-9+deb8u14.4.1-9+deb8u104.4.1-9+deb8u24.4.1-9+deb8u3
Show 6 moreShow less
4.4.1-9+deb8u44.4.1-9+deb8u54.4.1-9+deb8u64.4.1-9+deb8u74.4.1-9+deb8u84.4.1-9+deb8u9
4.4.4lts1-0+deb8u1
xen
Ubuntu:14.04:LTS
before 4.4.2-0ubuntu0.14.04.11, plus listed versions
4.3.0-1ubuntu14.3.0-1ubuntu24.3.0-1ubuntu34.3.0-1ubuntu44.3.0-1ubuntu5
Show 20 moreShow less
4.4.0-0ubuntu34.4.0-0ubuntu44.4.0-0ubuntu54.4.0-0ubuntu5.14.4.0-0ubuntu5.24.4.1-0ubuntu0.14.04.14.4.1-0ubuntu0.14.04.24.4.1-0ubuntu0.14.04.34.4.1-0ubuntu0.14.04.44.4.1-0ubuntu0.14.04.54.4.1-0ubuntu0.14.04.64.4.2-0ubuntu0.14.04.14.4.2-0ubuntu0.14.04.24.4.2-0ubuntu0.14.04.34.4.2-0ubuntu0.14.04.44.4.2-0ubuntu0.14.04.54.4.2-0ubuntu0.14.04.64.4.2-0ubuntu0.14.04.74.4.2-0ubuntu0.14.04.94.4.2-0ubuntu0.14.04.10
4.4.2-0ubuntu0.14.04.11
xen
Ubuntu:16.04:LTS
before 4.6.5-0ubuntu1, plus listed versions
4.5.1-0ubuntu14.5.1-0ubuntu24.6.0-1ubuntu14.6.0-1ubuntu24.6.0-1ubuntu44.6.0-1ubuntu4.14.6.0-1ubuntu4.24.6.0-1ubuntu4.3
4.6.5-0ubuntu1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-14431 is a medium vulnerability (CVSS 5.5) in Xen, published September 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in xen 4.8.1-1.

References

MoveEnter Open