CVE-2017-14724
Before version 4.8.2, WordPress was vulnerable to cross-site scripting in oEmbed discovery.
Before version 4.8.2, WordPress was vulnerable to cross-site scripting in oEmbed discovery.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Before version 4.8.2, WordPress was vulnerable to cross-site scripting in oEmbed discovery.
- Record
CVE-2017-14724- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Before version 4.8.2, WordPress was vulnerable to cross-site scripting in oEmbed discovery.
- Record
CVE-2017-14724- Updated
- 2026-11-02
EUVDEUVD-2017-6221 No score
Before version 4.8.2, WordPress was vulnerable to cross-site scripting in oEmbed discovery.
- Record
EUVD-2017-6221- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7x3g-chv4-38jw
6.1
Before version 4.8.2, WordPress was vulnerable to cross-site scripting in oEmbed discovery.
Before version 4.8.2, WordPress was vulnerable to cross-site scripting in oEmbed discovery.
- Record
GHSA-7x3g-chv4-38jw- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Before version 4.8.2, WordPress was vulnerable to cross-site scripting in oEmbed discovery.
- Record
CVE-2017-14724- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-14724
6.1
Before version 4.8.2, WordPress was vulnerable to cross-site scripting in oEmbed discovery.
- Record
DEBIAN-CVE-2017-14724- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-14724
6.1
Before version 4.8.2, WordPress was vulnerable to cross-site scripting in oEmbed discovery.
- Record
UBUNTU-CVE-2017-14724- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressDebian:12 |
before 4.8.2+dfsg-1 | 4.8.2+dfsg-1 |
wordpressDebian:13 |
before 4.8.2+dfsg-1 | 4.8.2+dfsg-1 |
wordpressDebian:14 |
before 4.8.2+dfsg-1 | 4.8.2+dfsg-1 |
wordpressUbuntu:16.04:LTS |
All versions, plus listed versions 4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-14724 is a medium vulnerability (CVSS 6.1) in Wordpress, published September 23, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.56%, the 85th percentile. Fixed in wordpress 4.8.2+dfsg-1.