CVE-2017-14735
OWASP AntiSamy Cross-site Scripting vulnerability
OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of : to construct a javascript: URL.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of : to construct a javascript: URL.
- Record
CVE-2017-14735- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of : to construct a javascript: URL.
- Record
CVE-2017-14735- Updated
- 2026-11-02
EUVDEUVD-2018-0657 No score
OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of : to construct a javascript: URL.
- Record
EUVD-2018-0657- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q44v-xc3g-v7jq
6.1
OWASP AntiSamy Cross-site Scripting vulnerability
OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of : to construct a javascript: URL.
- Record
GHSA-q44v-xc3g-v7jq- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of : to construct a javascript: URL.
- Record
CVE-2017-14735- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-14735
6.1
OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of : to construct a javascript: URL.
- Record
DEBIAN-CVE-2017-14735- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-q44v-xc3g-v7jq
6.1
OWASP AntiSamy Cross-site Scripting vulnerability
OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of : to construct a javascript: URL.
- Record
GHSA-q44v-xc3g-v7jq- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-14735
6.1
OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of : to construct a javascript: URL.
- Record
UBUNTU-CVE-2017-14735- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.owasp.antisamy:antisamyMaven |
before 1.5.7 | 1.5.7 |
libowasp-antisamy-javaDebian:12 |
All versions, plus listed versions 1.5.3+dfsg-1.11.7.4-1 |
None known |
libowasp-antisamy-javaDebian:13 |
before 1.7.4-1 | 1.7.4-1 |
libowasp-antisamy-javaDebian:14 |
before 1.7.4-1 | 1.7.4-1 |
org.owasp.antisamy:antisamyMaven |
before 1.5.7, plus listed versions 1.4.21.4.31.4.41.4.51.5 Show 5 moreShow less1.5.11.5.21.5.31.5.51.5.6 |
1.5.7 |
libowasp-antisamy-javaUbuntu:16.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1 |
None known |
libowasp-antisamy-javaUbuntu:18.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1 |
None known |
libowasp-antisamy-javaUbuntu:20.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1 |
None known |
libowasp-antisamy-javaUbuntu:22.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1.1 |
None known |
libowasp-antisamy-javaUbuntu:24.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1.11.7.4-1 |
None known |
libowasp-antisamy-javaUbuntu:25.10 |
All versions, plus listed versions 1.7.4-1 |
None known |
libowasp-antisamy-javaUbuntu:26.10 |
All versions, plus listed versions 1.7.4-1 |
None known |
libowasp-antisamy-javaUbuntu:26.04:LTS |
All versions, plus listed versions 1.7.4-1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | shoucheng3/nahsra__antisamy_CVE-2017-14735_1-5-6 | 2025-08-20 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-14735 is a medium vulnerability (CVSS 6.1) in Antisamy Project Antisamy, published September 25, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.66%, the 76th percentile. Fixed in org.owasp.antisamy:antisamy 1.5.7.
References
securityfocus.com/bid/105656
oracle.com/security-alerts/cpuapr2020.html
oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
oracle.com/security-alerts/cpujan2020.html
Show 9 moreShow less
oracle.com/security-alerts/cpuApr2021.html
github.com/nahsra/antisamy/issues/10
oracle.com//security-alerts/cpujul2021.html
nvd.nist.gov/vuln/detail/CVE-2017-14735
github.com/advisories/GHSA-q44v-xc3g-v7jq
security-tracker.debian.org/tracker/CVE-2017-14735
github.com/nahsra/antisamy
ubuntu.com/security/CVE-2017-14735
cve.org/CVERecord?id=CVE-2017-14735