CVE-2017-14775
Laravel Encrypter Component Potential Decryption Failure Leading to Unintended Behavior
Laravel before 5.5.10 mishandles the remember_me token verification process because DatabaseUserProvider does not have constant-time token comparison.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.9
Laravel before 5.5.10 mishandles the remember_me token verification process because DatabaseUserProvider does not have constant-time token comparison.
- Record
CVE-2017-14775- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
Laravel before 5.5.10 mishandles the remember_me token verification process because DatabaseUserProvider does not have constant-time token comparison.
- Record
CVE-2017-14775- Updated
- 2026-11-02
EUVDEUVD-2022-3480 No score
Laravel before 5.5.10 mishandles the remember_me token verification process because DatabaseUserProvider does not have constant-time token comparison.
- Record
EUVD-2022-3480- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c2v7-j5gq-wcq4
5.9
Laravel Sensitive Data Exposure
Laravel before 5.5.10 mishandles the remember_me token verification process because DatabaseUserProvider does not have constant-time token comparison.
- Record
GHSA-c2v7-j5gq-wcq4- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-7852-w36x-6mf6 No score
Laravel Encrypter Component Potential Decryption Failure Leading to Unintended Behavior
The Laravel Encrypter component is susceptible to a vulnerability that may result in decryption failure, leading to an unexpected return of false. Exploiting this issue requires the attacker to manipulate the encrypted payload before decryption. When combined with weak type comparisons in the application's code, such as the example below:
<?php
$decyptedValue = decrypt($secret);
if ($decryptedValue == '') {
// Code is run even though decrypted value is false...
}
- Record
GHSA-7852-w36x-6mf6- Weakness
- CWE-1240
- Updated
- 2026-11-02
OSV
5.9
Laravel before 5.5.10 mishandles the remember_me token verification process because DatabaseUserProvider does not have constant-time token comparison.
- Record
CVE-2017-14775- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-c2v7-j5gq-wcq4
5.9
Laravel Sensitive Data Exposure
Laravel before 5.5.10 mishandles the remember_me token verification process because DatabaseUserProvider does not have constant-time token comparison.
- Record
GHSA-c2v7-j5gq-wcq4- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSVCLSA-2026-1773017339 No score
TuxCare security update for laravel/framework (10 CVEs)
TuxCare rebuilt laravel/framework to address 10 CVEs. Fixed in 5.4.36-p2+tuxcare.
- Record
CLSA-2026-1773017339- Updated
- 2026-11-02
OSVGHSA-7852-w36x-6mf6 No score
Laravel Encrypter Component Potential Decryption Failure Leading to Unintended Behavior
The Laravel Encrypter component is susceptible to a vulnerability that may result in decryption failure, leading to an unexpected return of false. Exploiting this issue requires the attacker to manipulate the encrypted payload before decryption. When combined with weak type comparisons in the application's code, such as the example below:
<?php
$decyptedValue = decrypt($secret);
if ($decryptedValue == '') {
// Code is run even though decrypted value is false...
}
- Record
GHSA-7852-w36x-6mf6- Weakness
- CWE-1240
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
laravel/frameworkPackagist |
before 5.5.40 | 5.5.40 |
laravel/frameworkPackagist |
5.6.0 up to 5.6.15 | 5.6.15 |
laravel/frameworkPackagist |
before 5.5.10 | 5.5.10 |
illuminate/authPackagist |
before 5.5.10 | 5.5.10 |
laravel/frameworkTuxCare:Packagist |
5.4.36 up to 5.4.36-p2+tuxcare, plus listed versions 5.4.36-p1+tuxcare |
5.4.36-p2+tuxcare |
laravel/frameworkPackagist |
before 5.5.40, plus listed versions 5.0.305.2.41v4.0.0v4.0.0-BETA2v4.0.0-BETA3 Show 45 moreShow lessv4.0.0-BETA4v4.0.1v4.0.10v4.0.11v4.0.2v4.0.3v4.0.4v4.0.5v4.0.6v4.0.7v4.0.8v4.0.9v4.1.0v4.1.1v4.1.10v4.1.11v4.1.12v4.1.13v4.1.14v4.1.15v4.1.16v4.1.17v4.1.18v4.1.19v4.1.2v4.1.20v4.1.21v4.1.22v4.1.23v4.1.24v4.1.25v4.1.26v4.1.27v4.1.28v4.1.29v4.1.3v4.1.30v4.1.31v4.1.4v4.1.5v4.1.6v4.1.7v4.1.8v4.1.9v4.2.0 |
5.5.40 |
laravel/frameworkPackagist |
5.6.0 up to 5.6.15, plus listed versions v5.6.0v5.6.1v5.6.10v5.6.11v5.6.12 Show 10 moreShow lessv5.6.13v5.6.14v5.6.2v5.6.3v5.6.4v5.6.5v5.6.6v5.6.7v5.6.8v5.6.9 |
5.6.15 |
laravel/frameworkPackagist |
before 5.5.10, plus listed versions 5.0.305.2.41v4.0.0v4.0.0-BETA2v4.0.0-BETA3 Show 45 moreShow lessv4.0.0-BETA4v4.0.1v4.0.10v4.0.11v4.0.2v4.0.3v4.0.4v4.0.5v4.0.6v4.0.7v4.0.8v4.0.9v4.1.0v4.1.1v4.1.10v4.1.11v4.1.12v4.1.13v4.1.14v4.1.15v4.1.16v4.1.17v4.1.18v4.1.19v4.1.2v4.1.20v4.1.21v4.1.22v4.1.23v4.1.24v4.1.25v4.1.26v4.1.27v4.1.28v4.1.29v4.1.3v4.1.30v4.1.31v4.1.4v4.1.5v4.1.6v4.1.7v4.1.8v4.1.9v4.2.0 |
5.5.10 |
illuminate/authPackagist |
before 5.5.10, plus listed versions v1.0.0v1.1.0v4.0.0v4.0.0-BETA2v4.0.0-BETA3 Show 45 moreShow lessv4.0.0-BETA4v4.0.1v4.0.10v4.0.2v4.0.3v4.0.4v4.0.5v4.0.6v4.0.7v4.0.8v4.0.9v4.1.0v4.1.1v4.1.10v4.1.11v4.1.12v4.1.13v4.1.14v4.1.15v4.1.16v4.1.17v4.1.18v4.1.19v4.1.2v4.1.20v4.1.21v4.1.22v4.1.23v4.1.24v4.1.25v4.1.26v4.1.27v4.1.28v4.1.29v4.1.3v4.1.30v4.1.4v4.1.5v4.1.6v4.1.7v4.1.8v4.1.9v4.2.0-BETA1v4.2.1v4.2.12 |
5.5.10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-14775 is a medium vulnerability (CVSS 5.9) in Laravel, published September 27, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 68th percentile. Fixed in laravel/framework 5.5.40.
References
github.com/laravel/framework/releases/tag/v5.5.10
github.com/laravel/framework/pull/21320
laravel-news.com/laravel-v5-5-11
github.com/laravel/framework/commit/28e53f23a76206fb130e9a54eb95aa3f010e79c9
github.com/laravel/framework/commit/886d261df0854426b4662b7ed5db6a1c575a4279
github.com/FriendsOfPHP/security-advisories/blob/master/laravel/framework/2018-03-30-1.yaml
Show 7 moreShow less
medium.com/@taylorotwell/laravel-security-release-5-6-15-and-5-5-40-56f1257933a0
github.com/advisories/GHSA-7852-w36x-6mf6
nvd.nist.gov/vuln/detail/CVE-2017-14775
github.com/FriendsOfPHP/security-advisories/blob/master/illuminate/auth/CVE-2017-14775.yaml
github.com/FriendsOfPHP/security-advisories/blob/master/laravel/framework/CVE-2017-14775.yaml
github.com/advisories/GHSA-c2v7-j5gq-wcq4
github.com/laravel/framework
Left out here: 550 versions. The JSON record has them.