Every CVE Search/ Get API key

CVE-2017-15694

Argument Injection in Apache Geode server

6.5 MediumFix available

CVE-2017-15694 is a medium vulnerability (CVSS 6.5) in Apache Geode, published June 21, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.15%, the 82nd percentile. Fixed in org.apache.geode:geode-core 1.9.0.

When an Apache Geode server versions 1.0.0 to 1.8.0 is operating in secure mode, a user with write permissions for specific data regions can modify internal cluster metadata. A malicious user could modify this data in a way that affects the operation of the cluster.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

2.15%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

When an Apache Geode server versions 1.0.0 to 1.8.0 is operating in secure mode, a user with write permissions for specific data regions can modify internal cluster metadata. A malicious user could modify this data in a way that affects the operation of the cluster.

Record
CVE-2017-15694
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Weakness
CWE-88
Updated
2026-11-02
CVE List No score

When an Apache Geode server versions 1.0.0 to 1.8.0 is operating in secure mode, a user with write permissions for specific data regions can modify internal cluster metadata. A malicious user could modify this data in a way that affects the operation of the cluster.

Record
CVE-2017-15694
Updated
2026-11-02
EUVDEUVD-2019-0553 No score

When an Apache Geode server versions 1.0.0 to 1.8.0 is operating in secure mode, a user with write permissions for specific data regions can modify internal cluster metadata. A malicious user could modify this data in a way that affects the operation of the cluster.

Record
EUVD-2019-0553
Updated
2026-11-03
GitHub AdvisoriesGHSA-p426-qw2p-v95v 6.5

Argument Injection in Apache Geode server

When an Apache Geode server versions 1.0.0 to 1.8.0 is operating in secure mode, a user with write permissions for specific data regions can modify internal cluster metadata. A malicious user could modify this data in a way that affects the operation of the cluster.

Record
GHSA-p426-qw2p-v95v
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-88
Updated
2026-11-02
OSV 6.5

When an Apache Geode server versions 1.0.0 to 1.8.0 is operating in secure mode, a user with write permissions for specific data regions can modify internal cluster metadata. A malicious user could modify this data in a way that affects the operation of the cluster.

Record
CVE-2017-15694
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-p426-qw2p-v95v 6.5

Argument Injection in Apache Geode server

When an Apache Geode server versions 1.0.0 to 1.8.0 is operating in secure mode, a user with write permissions for specific data regions can modify internal cluster metadata. A malicious user could modify this data in a way that affects the operation of the cluster.

Record
GHSA-p426-qw2p-v95v
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-88
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.geode:geode-core
Maven
before 1.9.0
1.9.0
org.apache.geode:geode-core
Maven
before 1.9.0, plus listed versions
1.0.0-incubating1.0.0-incubating.M21.0.0-incubating.M31.1.01.1.1
Show 8 moreShow less
1.2.01.2.11.3.01.4.01.5.01.6.01.7.01.8.0
1.9.0

History

History
WhenChangedSources
2026-11-03aliases, productsEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open