CVE-2017-15695
Apache Geode vulnerable to Incorrect Authorization
CVE-2017-15695 is a high vulnerability (CVSS 8.8) in Apache Geode, published June 13, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.51%, the 84th percentile. Fixed in org.apache.geode:geode-core 1.5.0.
When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to deploy code by invoking an internal Geode function. This allows remote code execution. Code deployment should be restricted to users with DATA:MANAGE privilege.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to deploy code by invoking an internal Geode function. This allows remote code execution. Code deployment should be restricted to users with DATA:MANAGE privilege.
- Record
CVE-2017-15695- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-863
- Updated
- 2026-11-02
CVE List No score
When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to deploy code by invoking an internal Geode function. This allows remote code execution. Code deployment should be restricted to users with DATA:MANAGE privilege.
- Record
CVE-2017-15695- Updated
- 2026-11-02
EUVDEUVD-2022-4398 No score
When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to deploy code by invoking an internal Geode function. This allows remote code execution. Code deployment should be restricted to users with DATA:MANAGE privilege.
- Record
EUVD-2022-4398- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jmg4-x4vp-6c6x
8.8
Apache Geode vulnerable to Incorrect Authorization
When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to deploy code by invoking an internal Geode function. This allows remote code execution. Code deployment should be restricted to users with DATA:MANAGE privilege.
- Record
GHSA-jmg4-x4vp-6c6x- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-863
- Updated
- 2026-11-02
OSV
8.8
When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to deploy code by invoking an internal Geode function. This allows remote code execution. Code deployment should be restricted to users with DATA:MANAGE privilege.
- Record
CVE-2017-15695- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-jmg4-x4vp-6c6x
8.8
Apache Geode vulnerable to Incorrect Authorization
When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to deploy code by invoking an internal Geode function. This allows remote code execution. Code deployment should be restricted to users with DATA:MANAGE privilege.
- Record
GHSA-jmg4-x4vp-6c6x- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-863
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.geode:geode-coreMaven |
1.0.0 up to 1.5.0 | 1.5.0 |
org.apache.geode:geode-coreMaven |
1.0.0 up to 1.5.0, plus listed versions 1.0.0-incubating1.0.0-incubating.M21.0.0-incubating.M31.1.01.1.1 Show 4 moreShow less1.2.01.2.11.3.01.4.0 |
1.5.0 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
lists.apache.org/thread.html/dc8875c0b924885a884eba6d5bd7dc3f123411b2d33cffd00e351c99%40%3Cuser.geode.apache.org%3E
securityfocus.com/bid/104465
nvd.nist.gov/vuln/detail/CVE-2017-15695
lists.apache.org/thread.html/dc8875c0b924885a884eba6d5bd7dc3f123411b2d33cffd00e351c99@%3Cuser.geode.apache.org%3E
github.com/apache/geode/pull/1258
cwiki.apache.org/confluence/display/GEODE/Release+Notes
Show 10 moreShow less
issues.apache.org/jira/browse/GEODE-3974
github.com/apache/geode/commit/00be4f9774e1adf8e7ccc2664da8005fc30bb11d
github.com/apache/geode/commit/49d28f93fd2ef069693ce15d124ef3a29f22fb7d
github.com/apache/geode/commit/6df14c8b1e3c644f9f810149e80bba0c2f073dab
github.com/apache/geode/commit/740289c61d60256c6270756bc84b9e24b76e4913
github.com/apache/geode/commit/90f8f6242927c5e16da64f38bba9abf3d450a305
github.com/apache/geode/commit/954ccb545d24a9c9a35cbd84023a4d7e07032de0
github.com/apache/geode/commit/aa469239860778eb46e09dd7b390aee08f152480
github.com/advisories/GHSA-jmg4-x4vp-6c6x
github.com/apache/geode