CVE-2017-15914
Borg Improper Access Control vulnerability
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
- Record
CVE-2017-15914- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
- Record
CVE-2017-15914- Updated
- 2026-11-02
EUVDEUVD-2018-0027 No score
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
- Record
EUVD-2018-0027- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8q8v-28rm-qw4w
8.8
Borg Improper Access Control vulnerability
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
- Record
GHSA-8q8v-28rm-qw4w- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-284
- Updated
- 2026-11-02
OSV
8.8
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
- Record
CVE-2017-15914- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-15914
8.8
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
- Record
DEBIAN-CVE-2017-15914- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-8q8v-28rm-qw4w
8.8
Borg Improper Access Control vulnerability
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
- Record
GHSA-8q8v-28rm-qw4w- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-284
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-15914
8.8
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
- Record
UBUNTU-CVE-2017-15914- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10659-1 No score
borgbackup-1.1.17-1.2 on GA media
These are all security issues fixed in the borgbackup-1.1.17-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10659-1- Updated
- 2026-11-02
OSVPYSEC-2018-105 No score
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
- Record
PYSEC-2018-105- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
borgbackupPyPI |
1.1.0b1 up to 1.1.3 | 1.1.3 |
borgbackupDebian:12 |
before 1.1.3-1 | 1.1.3-1 |
borgbackupDebian:13 |
before 1.1.3-1 | 1.1.3-1 |
borgbackupDebian:14 |
before 1.1.3-1 | 1.1.3-1 |
borgbackupPyPI |
1.1.0b1 up to 1.1.3, plus listed versions 1.1.01.1.0b21.1.0b31.1.0b41.1.0b5 Show 7 moreShow less1.1.0b61.1.0rc11.1.0rc21.1.0rc31.1.0rc41.1.11.1.2 |
1.1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-15914 is a high vulnerability (CVSS 8.8) in Borgbackup Borg, published February 8, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.92%, the 79th percentile. Fixed in borgbackup 1.1.3.
References
borgbackup.readthedocs.io/en/stable/changes.html
nvd.nist.gov/vuln/detail/CVE-2017-15914
github.com/borgbackup/borg/commit/75854c1243b29ec5558be6fdefe365cd438abb4c
github.com/pypa/advisory-database/tree/main/vulns/borgbackup/PYSEC-2018-105.yaml
github.com/advisories/GHSA-8q8v-28rm-qw4w
security-tracker.debian.org/tracker/CVE-2017-15914