Every CVE Search/ Get API key

CVE-2017-16006

XSS in Data URI in remarkable

6.1 MediumFix available

Remarkable is a markdown parser. In versions 1.6.2 and lower, remarkable allows the use of data: URIs in links and can therefore execute javascript.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.96%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

Remarkable is a markdown parser. In versions 1.6.2 and lower, remarkable allows the use of data: URIs in links and can therefore execute javascript.

Record
CVE-2017-16006
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Remarkable is a markdown parser. In versions 1.6.2 and lower, remarkable allows the use of data: URIs in links and can therefore execute javascript.

Record
CVE-2017-16006
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2018-0762 No score

Remarkable is a markdown parser. In versions 1.6.2 and lower, remarkable allows the use of data: URIs in links and can therefore execute javascript.

Record
EUVD-2018-0762
Updated
2026-11-03
GitHub AdvisoriesGHSA-mrmf-qwxg-7c3h No score

XSS in Data URI in remarkable

Affected versions of remarkable are vulnerable to cross-site scripting. Vulnerable versions of the package allow the use of data: URIs in links, and can therefore execute javascript.

Proof of Concept

[link](data:text/html,<script>alert('0')</script>)

Recommendation

Update to v1.7.0 or later

Record
GHSA-mrmf-qwxg-7c3h
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Remarkable is a markdown parser. In versions 1.6.2 and lower, remarkable allows the use of data: URIs in links and can therefore execute javascript.

Record
CVE-2017-16006
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-mrmf-qwxg-7c3h No score

XSS in Data URI in remarkable

Affected versions of remarkable are vulnerable to cross-site scripting. Vulnerable versions of the package allow the use of data: URIs in links, and can therefore execute javascript.

Proof of Concept

[link](data:text/html,<script>alert('0')</script>)

Recommendation

Update to v1.7.0 or later

Record
GHSA-mrmf-qwxg-7c3h
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
remarkable
npm
through 1.6.2
1.7.0
remarkable
npm
before 1.7.0
1.7.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-16006 is a medium vulnerability (CVSS 6.1) in Remarkable Project Remarkable, published June 4, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.96%, the 61st percentile. Fixed in remarkable 1.7.0.

References

MoveEnter Open