Every CVE Search/ Get API key

CVE-2017-16014

Insufficient Error Handling in http-proxy

7.5 HighFix available

CVE-2017-16014 is a high vulnerability (CVSS 7.5) in Http-proxy Project Http-proxy, published June 4, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.66%, the 76th percentile. Fixed in http-proxy 0.7.0.

Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.66%Up 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.

Record
CVE-2017-16014
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-703, CWE-388
Updated
2026-11-02
CVE List No score

Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.

Record
CVE-2017-16014
Weakness
CWE-703
Updated
2026-11-02
EUVDEUVD-2018-0743 No score

Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.

Record
EUVD-2018-0743
Updated
2026-11-03
GitHub AdvisoriesGHSA-9xw9-pvgv-6p76 7.5

Insufficient Error Handling in http-proxy

Affected versions of http-proxy are vulnerable to a denial of service attack, wherein an attacker can force an error which will cause the server to crash.

Recommendation

Update to version 0.7.0 or later.

Record
GHSA-9xw9-pvgv-6p76
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-703
Updated
2026-11-02
OSV 7.5

Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.

Record
CVE-2017-16014
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-9xw9-pvgv-6p76 7.5

Insufficient Error Handling in http-proxy

Affected versions of http-proxy are vulnerable to a denial of service attack, wherein an attacker can force an error which will cause the server to crash.

Recommendation

Update to version 0.7.0 or later.

Record
GHSA-9xw9-pvgv-6p76
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-703
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
http-proxy
npm
through 0.6.6
0.7.0
http-proxy
npm
before 0.7.0
0.7.0

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open