CVE-2017-16015
Cross-Site Scripting in forms
CVE-2017-16015 is a medium vulnerability (CVSS 6.1) in Forms Project Forms, published June 4, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.83%, the 57th percentile. Fixed in forms 1.3.0.
Forms is a library for easily creating HTML forms. Versions before 1.3.0 did not have proper html escaping. This means that if the application did not sanitize html on behalf of forms, use of forms may be vulnerable to cross site scripting
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Forms is a library for easily creating HTML forms. Versions before 1.3.0 did not have proper html escaping. This means that if the application did not sanitize html on behalf of forms, use of forms may be vulnerable to cross site scripting
- Record
CVE-2017-16015- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-80, CWE-79
- Updated
- 2026-11-02
CVE List No score
Forms is a library for easily creating HTML forms. Versions before 1.3.0 did not have proper html escaping. This means that if the application did not sanitize html on behalf of forms, use of forms may be vulnerable to cross site scripting
- Record
CVE-2017-16015- Weakness
- CWE-80
- Updated
- 2026-11-02
EUVDEUVD-2018-0780 No score
Forms is a library for easily creating HTML forms. Versions before 1.3.0 did not have proper html escaping. This means that if the application did not sanitize html on behalf of forms, use of forms may be vulnerable to cross site scripting
- Record
EUVD-2018-0780- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vwjj-2852-3765
6.1
Cross-Site Scripting in forms
Affected versions of forms do not properly escape HTML in generated forms, which may result in cross-site scripting.
Recommendation
Update to version 1.3.0 or later.
- Record
GHSA-vwjj-2852-3765- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-80
- Updated
- 2026-11-02
OSV
6.1
Forms is a library for easily creating HTML forms. Versions before 1.3.0 did not have proper html escaping. This means that if the application did not sanitize html on behalf of forms, use of forms may be vulnerable to cross site scripting
- Record
CVE-2017-16015- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-vwjj-2852-3765
6.1
Cross-Site Scripting in forms
Affected versions of forms do not properly escape HTML in generated forms, which may result in cross-site scripting.
Recommendation
Update to version 1.3.0 or later.
- Record
GHSA-vwjj-2852-3765- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-80
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
formsnpm |
before 1.3.0 | 1.3.0 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |