CVE-2017-16816
The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote...
The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote authenticated users to cause a denial of service (daemon crash) by leveraging use of GSI and VOMS extensions.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote authenticated users to cause a denial of service (daemon crash) by leveraging use of GSI and VOMS extensions.
- Record
CVE-2017-16816- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote authenticated users to cause a denial of service (daemon crash) by leveraging use of GSI and VOMS extensions.
- Record
CVE-2017-16816- Updated
- 2026-11-02
EUVDEUVD-2017-7991 No score
The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote authenticated users to cause a denial of service (daemon crash) by leveraging use of GSI and VOMS extensions.
- Record
EUVD-2017-7991- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9x52-5xwr-hfwc
6.5
The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote...
The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote authenticated users to cause a denial of service (daemon crash) by leveraging use of GSI and VOMS extensions.
- Record
GHSA-9x52-5xwr-hfwc- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
6.5
The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote authenticated users to cause a denial of service (daemon crash) by leveraging use of GSI and VOMS extensions.
- Record
CVE-2017-16816- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-16816
6.5
The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote authenticated users to cause a denial of service (daemon crash) by leveraging use of GSI and VOMS extensions.
- Record
DEBIAN-CVE-2017-16816- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-16816
6.5
The condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote authenticated users to cause a denial of service (daemon crash) by leveraging use of GSI and VOMS extensions.
- Record
UBUNTU-CVE-2017-16816- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-4771-1 No score
condor vulnerabilities
It was discovered that HTCondor incorrectly invoked the mailx utility. An attacker could use this vulnerability to execute arbitrary commands. This issue only affected Ubuntu 14.04 ESM. (CVE-2014-8126)
It was discovered that HTCondor mishandled certain crafted input. An attacker could use this vulnerability to cause HTCondor to crash. (CVE-2017-16816)
- Record
USN-4771-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
condorDebian:13 |
before 8.6.8~dfsg.1-1 | 8.6.8~dfsg.1-1 |
condorDebian:14 |
before 8.6.8~dfsg.1-1 | 8.6.8~dfsg.1-1 |
condorUbuntu:Pro:14.04:LTS |
before 8.0.5~dfsg.1-1ubuntu1+esm1, plus listed versions 7.8.8~dfsg.1-27.8.8~dfsg.1-2.18.0.5~dfsg.1-1ubuntu1 |
8.0.5~dfsg.1-1ubuntu1+esm1 |
condorUbuntu:Pro:16.04:LTS |
before 8.4.2~dfsg.1-1ubuntu0.1~esm1, plus listed versions 8.2.9~dfsg.1-18.4.2~dfsg.1-18.4.2~dfsg.1-1build1 |
8.4.2~dfsg.1-1ubuntu0.1~esm1 |
condorUbuntu:Pro:14.04:LTS From an advisory covering 2 CVEs |
before 8.0.5~dfsg.1-1ubuntu1+esm1, plus listed versions 7.8.8~dfsg.1-27.8.8~dfsg.1-2.18.0.5~dfsg.1-1ubuntu1 |
8.0.5~dfsg.1-1ubuntu1+esm1 |
condorUbuntu:Pro:16.04:LTS From an advisory covering 2 CVEs |
before 8.4.2~dfsg.1-1ubuntu0.1~esm1, plus listed versions 8.2.9~dfsg.1-18.4.2~dfsg.1-18.4.2~dfsg.1-1build1 |
8.4.2~dfsg.1-1ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-16816 is a medium vulnerability (CVSS 6.5) in Wisc Htcondor, published July 5, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.68%, the 76th percentile. Fixed in condor 8.6.8~dfsg.1-1.
References
www-auth.cs.wisc.edu/lists/htcondor-users/2017-November/msg00022.shtml
research.cs.wisc.edu/htcondor/security/vulnerabilities/HTCONDOR-2017-0001.html
nvd.nist.gov/vuln/detail/CVE-2017-16816
github.com/advisories/GHSA-9x52-5xwr-hfwc
security-tracker.debian.org/tracker/CVE-2017-16816
ubuntu.com/security/CVE-2017-16816
cve.org/CVERecord?id=CVE-2017-16816
ubuntu.com/security/notices/USN-4771-1
ubuntu.com/security/CVE-2014-8126