Every CVE Search/ Get API key

CVE-2017-16837

Certain function pointers in Trusted Boot (tboot) through 1.9.6 are not validated and can cause...

7.8 HighFix available

Certain function pointers in Trusted Boot (tboot) through 1.9.6 are not validated and can cause arbitrary code execution, which allows local users to overwrite dynamic PCRs of Trusted Platform Module (TPM) by hooking these function pointers.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.41%Down 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

Certain function pointers in Trusted Boot (tboot) through 1.9.6 are not validated and can cause arbitrary code execution, which allows local users to overwrite dynamic PCRs of Trusted Platform Module (TPM) by hooking these function pointers.

Record
CVE-2017-16837
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Certain function pointers in Trusted Boot (tboot) through 1.9.6 are not validated and can cause arbitrary code execution, which allows local users to overwrite dynamic PCRs of Trusted Platform Module (TPM) by hooking these function pointers.

Record
CVE-2017-16837
Updated
2026-11-02
EUVDEUVD-2017-8011 No score

Certain function pointers in Trusted Boot (tboot) through 1.9.6 are not validated and can cause arbitrary code execution, which allows local users to overwrite dynamic PCRs of Trusted Platform Module (TPM) by hooking these function pointers.

Record
EUVD-2017-8011
Updated
2026-11-03
GitHub AdvisoriesGHSA-86m6-cj8w-2c48 7.8

Certain function pointers in Trusted Boot (tboot) through 1.9.6 are not validated and can cause...

Certain function pointers in Trusted Boot (tboot) through 1.9.6 are not validated and can cause arbitrary code execution, which allows local users to overwrite dynamic PCRs of Trusted Platform Module (TPM) by hooking these function pointers.

Record
GHSA-86m6-cj8w-2c48
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVUBUNTU-CVE-2017-16837 7.8

Certain function pointers in Trusted Boot (tboot) through 1.9.6 are not validated and can cause arbitrary code execution, which allows local users to overwrite dynamic PCRs of Trusted Platform Module (TPM) by hooking these function pointers.

Record
UBUNTU-CVE-2017-16837
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:11424-1 No score

tboot-20210614_1.10.2-2.2 on GA media

These are all security issues fixed in the tboot-20210614_1.10.2-2.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11424-1
Updated
2026-11-02
OSVSUSE-SU-2017:3090-1 No score

Recommended update for tboot

This update for tboot fixes the following issues:

Security issue fixed:

  • CVE-2017-16837: Certain function pointers in Trusted Boot (tboot) through 1.9.6 are notvalidated and can cause arbitrary code execution, which allows local users tooverwrite dynamic PCRs of Trusted Platform Module (TPM) by h (bsc#1068390)

Bug fixes:

  • Fixed failed trusted boot on some systems like Intel Xeon 'Purley 8s' processors. The following error message showed: 'TBOOT: wait-for-sipi loop timed-out'. Booting continued but 'TXT measured launch' was wrongly reported as FALSE. (bsc#1057555)
Record
SUSE-SU-2017:3090-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
tboot
SUSE:Linux Enterprise Server 12 SP2
before 20160518_1.9.4-7.5.1
20160518_1.9.4-7.5.1
tboot
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 20160518_1.9.4-7.5.1
20160518_1.9.4-7.5.1
tboot
SUSE:Linux Enterprise Server 12 SP3
before 20160518_1.9.4-7.5.1
20160518_1.9.4-7.5.1
tboot
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 20160518_1.9.4-7.5.1
20160518_1.9.4-7.5.1
tboot
Ubuntu:16.04:LTS
All versions, plus listed versions
1.8.3-0ubuntu1
None known
tboot
Ubuntu:18.04:LTS
All versions, plus listed versions
1.9.6-0ubuntu1
None known
tboot
Ubuntu:20.04:LTS
before 1.9.7-0ubuntu1
1.9.7-0ubuntu1
tboot
openSUSE:Tumbleweed
before 20210614_1.10.2-2.2
20210614_1.10.2-2.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-16837 is a high vulnerability (CVSS 7.8) in Trusted Boot Project Boot, published November 16, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.41%, the 35th percentile. Fixed in tboot 20160518_1.9.4-7.5.1.

References

Show 4 moreShow less
MoveEnter Open