CVE-2017-17663
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by...
CVE-2017-17663 is a critical vulnerability (CVSS 9.8) in Acme Thttpd, published February 6, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.74%, the 86th percentile. Fixed in mini_httpd 1.29-r0.
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.
- Record
CVE-2017-17663- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.
- Record
CVE-2017-17663- Updated
- 2026-11-02
EUVDEUVD-2017-8821 No score
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.
- Record
EUVD-2017-8821- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mrjc-pvrp-jc53
9.8
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by...
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.
- Record
GHSA-mrjc-pvrp-jc53- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVALPINE-CVE-2017-17663
9.8
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.
- Record
ALPINE-CVE-2017-17663- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
9.8
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.
- Record
CVE-2017-17663- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-17663
9.8
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.
- Record
DEBIAN-CVE-2017-17663- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-17663
9.8
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.
- Record
UBUNTU-CVE-2017-17663- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11460-1 No score
thttpd-2.29-3.9 on GA media
These are all security issues fixed in the thttpd-2.29-3.9 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11460-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mini_httpdAlpine:v3.10 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.11 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.12 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.13 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.14 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.15 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.16 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.17 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.18 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.19 |
before 1.29-r0 | 1.29-r0 |
Show 14 moreShow less
| Package | Affected | Fixed |
|---|---|---|
mini_httpdAlpine:v3.20 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.21 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.22 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.23 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.24 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.8 |
before 1.29-r0 | 1.29-r0 |
mini_httpdAlpine:v3.9 |
before 1.29-r0 | 1.29-r0 |
mini-httpdDebian:12 |
All versions, plus listed versions 1.30-101.30-111.30-121.30-131.30-14 Show 11 moreShow less1.30-151.30-161.30-171.30-181.30-31.30-41.30-51.30-61.30-71.30-81.30-9 |
None known |
mini-httpdDebian:13 |
All versions, plus listed versions 1.30-131.30-141.30-151.30-161.30-171.30-18 |
None known |
mini-httpdDebian:14 |
All versions, plus listed versions 1.30-131.30-141.30-151.30-161.30-171.30-18 |
None known |
mini-httpdUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 1.19-9.31.19-9.3ubuntu0.1~esm1 |
None known |
mini-httpdUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.19-9.31.21-1ubuntu11.23-11.23-1ubuntu0.1~esm1 |
None known |
mini-httpdUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.23-1.21.23-1.2build11.23-1.2ubuntu0.1~esm1 |
None known |
thttpdopenSUSE:Tumbleweed |
before 2.29-3.9 | 2.29-3.9 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
acme.com/updates/archive/199.html
nvd.nist.gov/vuln/detail/CVE-2017-17663
github.com/advisories/GHSA-mrjc-pvrp-jc53
security.alpinelinux.org/vuln/CVE-2017-17663
security-tracker.debian.org/tracker/CVE-2017-17663
ubuntu.com/security/CVE-2017-17663
cve.org/CVERecord?id=CVE-2017-17663
suse.com/security/cve/CVE-2017-17663