Every CVE Search/ Get API key

CVE-2017-17788

In GIMP 2.8.22, there is a stack-based buffer over-read in xcf_load_stream in app/xcf/xcf.c when...

5.5 MediumFix available

In GIMP 2.8.22, there is a stack-based buffer over-read in xcf_load_stream in app/xcf/xcf.c when there is no '\0' character after the version string.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.13%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

In GIMP 2.8.22, there is a stack-based buffer over-read in xcf_load_stream in app/xcf/xcf.c when there is no '\0' character after the version string.

Record
CVE-2017-17788
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

In GIMP 2.8.22, there is a stack-based buffer over-read in xcf_load_stream in app/xcf/xcf.c when there is no '\0' character after the version string.

Record
CVE-2017-17788
Updated
2026-11-02
EUVDEUVD-2017-8939 No score

In GIMP 2.8.22, there is a stack-based buffer over-read in xcf_load_stream in app/xcf/xcf.c when there is no '\0' character after the version string.

Record
EUVD-2017-8939
Updated
2026-11-03
GitHub AdvisoriesGHSA-wqmm-5cp8-rhmw 5.5

In GIMP 2.8.22, there is a stack-based buffer over-read in xcf_load_stream in app/xcf/xcf.c when...

In GIMP 2.8.22, there is a stack-based buffer over-read in xcf_load_stream in app/xcf/xcf.c when there is no '\0' character after the version string.

Record
GHSA-wqmm-5cp8-rhmw
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 5.5

In GIMP 2.8.22, there is a stack-based buffer over-read in xcf_load_stream in app/xcf/xcf.c when there is no '\0' character after the version string.

Record
CVE-2017-17788
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-17788 5.5

In GIMP 2.8.22, there is a stack-based buffer over-read in xcf_load_stream in app/xcf/xcf.c when there is no '\0' character after the version string.

Record
DEBIAN-CVE-2017-17788
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2017-17788 5.5

In GIMP 2.8.22, there is a stack-based buffer over-read in xcf_load_stream in app/xcf/xcf.c when there is no '\0' character after the version string.

Record
UBUNTU-CVE-2017-17788
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0030 No score

Updated gimp packages fix security vulnerability

Several vulnerabilities were discovered in the GIMP which could result in denial of service (application crash) or potentially the execution of arbitrary code if malformed files are opened (CVE-2017-17784, CVE-2017-17785, CVE-2017-17786, CVE-2017-17787, CVE-2017-17788, CVE-2017-17789).

Record
MGASA-2018-0030
Updated
2026-11-02
OSVMGASA-2018-0273 No score

Updated gimp packages fix security vulnerabilities

Updated gimp packages fix security vulnerabilities:

Several vulnerabilities were discovered in GIMP which could result in denial of service (application crash) or potentially the execution of arbitrary code if malformed files are opened (CVE-2017-17784, CVE-2017-17785, CVE-2017-17786, CVE-2017-17787, CVE-2017-17788, CVE-2017-17789).

Also, the webkit1-based help browser plugin has been disabled in favor of using an external browser for the help pages. This is due to security issues in webkit.

Record
MGASA-2018-0273
Updated
2026-11-02
OSVSUSE-SU-2020:0601-1 No score

Security update for gimp

This update for gimp fixes the following issues:

  • Fix for crashing due to segmentation fault caused by importing ghostscript files. (bsc#1161998)

Security issues fixed:

  • CVE-2017-17785: Fixed an heap-based buffer overflow in FLI import (bsc#1073625)
  • CVE-2017-17786: Fixed an out-of-bounds read in TGA (bsc#1073626)
  • CVE-2017-17788: Fixed an out-of-bounds read in XCF (bsc#1073629)
Record
SUSE-SU-2020:0601-1
Updated
2026-11-02
OSVUSN-3539-1 No score

gimp vulnerabilities

It was discovered that GIMP incorrectly handled certain images. If a user were tricked into opening a specially crafted image, an attacker could possibly use this to execute arbitrary code. (CVE-2017-17784, CVE-2017-17785, CVE-2017-17786, CVE-2017-17787, CVE-2017-17788, CVE-2017-17789)

Record
USN-3539-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gimp
Debian:12
before 2.8.20-1.1
2.8.20-1.1
gimp
Debian:13
before 2.8.20-1.1
2.8.20-1.1
gimp
Debian:14
before 2.8.20-1.1
2.8.20-1.1
gimp
Debian:7
From an advisory covering 6 CVEs
before 2.8.2-2+deb7u3, plus listed versions
2.8.2-22.8.2-2+deb7u12.8.2-2+deb7u2
2.8.2-2+deb7u3
gimp
Debian:8
From an advisory covering 6 CVEs
before 2.8.14-1+deb8u2, plus listed versions
2.8.14-12.8.14-1+deb8u1
2.8.14-1+deb8u2
gimp
Debian:9
From an advisory covering 6 CVEs
before 2.8.18-1+deb9u1, plus listed versions
2.8.18-1
2.8.18-1+deb9u1
gimp
Mageia:5
From an advisory covering 6 CVEs
before 2.8.14-4.3.mga5
2.8.14-4.3.mga5
gimp
Mageia:6
From an advisory covering 6 CVEs
before 2.8.22-1.2.mga6
2.8.22-1.2.mga6
gimp
SUSE:Linux Enterprise Desktop 12 SP4
From an advisory covering 3 CVEs
before 2.8.18-9.8.1
2.8.18-9.8.1
gimp
SUSE:Linux Enterprise Software Development Kit 12 SP4
From an advisory covering 3 CVEs
before 2.8.18-9.8.1
2.8.18-9.8.1
Show 6 moreShow less
Affected packages
PackageAffectedFixed
gimp
SUSE:Linux Enterprise Software Development Kit 12 SP5
From an advisory covering 3 CVEs
before 2.8.18-9.8.1
2.8.18-9.8.1
gimp
SUSE:Linux Enterprise Workstation Extension 12 SP4
From an advisory covering 3 CVEs
before 2.8.18-9.8.1
2.8.18-9.8.1
gimp
SUSE:Linux Enterprise Workstation Extension 12 SP5
From an advisory covering 3 CVEs
before 2.8.18-9.8.1
2.8.18-9.8.1
gimp
Ubuntu:14.04:LTS
before 2.8.10-0ubuntu1.2, plus listed versions
2.8.6-1ubuntu12.8.6-1ubuntu22.8.6-1ubuntu32.8.10-0ubuntu12.8.10-0ubuntu1.1
2.8.10-0ubuntu1.2
gimp
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.8.14-1ubuntu22.8.14-1.2ubuntu12.8.16-1ubuntu12.8.16-1ubuntu1.12.8.16-1ubuntu1.1+esm12.8.16-1ubuntu1.1+esm22.8.16-1ubuntu1.1+esm3
None known
gimp
Ubuntu:14.04:LTS
From an advisory covering 6 CVEs
before 2.8.10-0ubuntu1.2, plus listed versions
2.8.6-1ubuntu12.8.6-1ubuntu22.8.6-1ubuntu32.8.10-0ubuntu12.8.10-0ubuntu1.1
2.8.10-0ubuntu1.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-17788 is a medium vulnerability (CVSS 5.5) in Gimp, published December 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.13%, the 66th percentile. Fixed in gimp 2.8.20-1.1.

References

Show 24 moreShow less
MoveEnter Open