Every CVE Search/ Get API key

CVE-2017-17789

In GIMP 2.8.22, there is a heap-based buffer overflow in read_channel_data in plug-ins/common...

7.8 HighFix available

In GIMP 2.8.22, there is a heap-based buffer overflow in read_channel_data in plug-ins/common/file-psp.c.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.95%Up 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

In GIMP 2.8.22, there is a heap-based buffer overflow in read_channel_data in plug-ins/common/file-psp.c.

Record
CVE-2017-17789
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

In GIMP 2.8.22, there is a heap-based buffer overflow in read_channel_data in plug-ins/common/file-psp.c.

Record
CVE-2017-17789
Updated
2026-11-02
EUVDEUVD-2017-8940 No score

In GIMP 2.8.22, there is a heap-based buffer overflow in read_channel_data in plug-ins/common/file-psp.c.

Record
EUVD-2017-8940
Updated
2026-11-03
GitHub AdvisoriesGHSA-45p4-vhwr-vrxr 7.8

In GIMP 2.8.22, there is a heap-based buffer overflow in read_channel_data in plug-ins/common...

In GIMP 2.8.22, there is a heap-based buffer overflow in read_channel_data in plug-ins/common/file-psp.c.

Record
GHSA-45p4-vhwr-vrxr
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 7.8

In GIMP 2.8.22, there is a heap-based buffer overflow in read_channel_data in plug-ins/common/file-psp.c.

Record
CVE-2017-17789
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-17789 7.8

In GIMP 2.8.22, there is a heap-based buffer overflow in read_channel_data in plug-ins/common/file-psp.c.

Record
DEBIAN-CVE-2017-17789
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 7 moreShow less
OSVUBUNTU-CVE-2017-17789 7.8

In GIMP 2.8.22, there is a heap-based buffer overflow in read_channel_data in plug-ins/common/file-psp.c.

Record
UBUNTU-CVE-2017-17789
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0030 No score

Updated gimp packages fix security vulnerability

Several vulnerabilities were discovered in the GIMP which could result in denial of service (application crash) or potentially the execution of arbitrary code if malformed files are opened (CVE-2017-17784, CVE-2017-17785, CVE-2017-17786, CVE-2017-17787, CVE-2017-17788, CVE-2017-17789).

Record
MGASA-2018-0030
Updated
2026-11-02
OSVMGASA-2018-0273 No score

Updated gimp packages fix security vulnerabilities

Updated gimp packages fix security vulnerabilities:

Several vulnerabilities were discovered in GIMP which could result in denial of service (application crash) or potentially the execution of arbitrary code if malformed files are opened (CVE-2017-17784, CVE-2017-17785, CVE-2017-17786, CVE-2017-17787, CVE-2017-17788, CVE-2017-17789).

Also, the webkit1-based help browser plugin has been disabled in favor of using an external browser for the help pages. This is due to security issues in webkit.

Record
MGASA-2018-0273
Updated
2026-11-02
OSVopenSUSE-SU-2020:1420-1 No score

Security update for gimp

This update for gimp fixes the following issue:

  • CVE-2017-17789: Fix heap buffer overflow in PSP importer (bsc#1073627).

This update was imported from the SUSE:SLE-15:Update update project.

Record
openSUSE-SU-2020:1420-1
Updated
2026-11-02
OSVSUSE-SU-2020:2603-1 No score

Security update for gimp

This update for gimp fixes the following issue:

  • CVE-2017-17789: Fix heap buffer overflow in PSP importer (bsc#1073627).
Record
SUSE-SU-2020:2603-1
Updated
2026-11-02
OSVSUSE-SU-2020:2604-1 No score

Security update for gimp

This update for gimp fixes the following issue:

  • CVE-2017-17789: Fix heap buffer overflow in PSP importer (bsc#1073627).
Record
SUSE-SU-2020:2604-1
Updated
2026-11-02
OSVUSN-3539-1 No score

gimp vulnerabilities

It was discovered that GIMP incorrectly handled certain images. If a user were tricked into opening a specially crafted image, an attacker could possibly use this to execute arbitrary code. (CVE-2017-17784, CVE-2017-17785, CVE-2017-17786, CVE-2017-17787, CVE-2017-17788, CVE-2017-17789)

Record
USN-3539-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gimp
Debian:12
before 2.8.20-1.1
2.8.20-1.1
gimp
Debian:13
before 2.8.20-1.1
2.8.20-1.1
gimp
Debian:14
before 2.8.20-1.1
2.8.20-1.1
gimp
Debian:7
From an advisory covering 6 CVEs
before 2.8.2-2+deb7u3, plus listed versions
2.8.2-22.8.2-2+deb7u12.8.2-2+deb7u2
2.8.2-2+deb7u3
gimp
Debian:8
From an advisory covering 6 CVEs
before 2.8.14-1+deb8u2, plus listed versions
2.8.14-12.8.14-1+deb8u1
2.8.14-1+deb8u2
gimp
Debian:9
From an advisory covering 6 CVEs
before 2.8.18-1+deb9u1, plus listed versions
2.8.18-1
2.8.18-1+deb9u1
gimp
Mageia:5
From an advisory covering 6 CVEs
before 2.8.14-4.3.mga5
2.8.14-4.3.mga5
gimp
Mageia:6
From an advisory covering 6 CVEs
before 2.8.22-1.2.mga6
2.8.22-1.2.mga6
gimp
SUSE:Linux Enterprise Software Development Kit 12 SP5
before 2.8.18-9.12.1
2.8.18-9.12.1
gimp
SUSE:Linux Enterprise Workstation Extension 12 SP5
before 2.8.18-9.12.1
2.8.18-9.12.1
Show 5 moreShow less
Affected packages
PackageAffectedFixed
gimp
SUSE:Linux Enterprise Workstation Extension 15 SP1
before 2.8.22-5.3.1
2.8.22-5.3.1
gimp
Ubuntu:14.04:LTS
before 2.8.10-0ubuntu1.2, plus listed versions
2.8.6-1ubuntu12.8.6-1ubuntu22.8.6-1ubuntu32.8.10-0ubuntu12.8.10-0ubuntu1.1
2.8.10-0ubuntu1.2
gimp
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.8.14-1ubuntu22.8.14-1.2ubuntu12.8.16-1ubuntu12.8.16-1ubuntu1.12.8.16-1ubuntu1.1+esm12.8.16-1ubuntu1.1+esm22.8.16-1ubuntu1.1+esm3
None known
gimp
Ubuntu:14.04:LTS
From an advisory covering 6 CVEs
before 2.8.10-0ubuntu1.2, plus listed versions
2.8.6-1ubuntu12.8.6-1ubuntu22.8.6-1ubuntu32.8.10-0ubuntu12.8.10-0ubuntu1.1
2.8.10-0ubuntu1.2
gimp
openSUSE:Leap 15.1
before 2.8.22-lp151.5.3.1
2.8.22-lp151.5.3.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-17789 is a high vulnerability (CVSS 7.8) in Gimp, published December 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.95%, the 80th percentile. Fixed in gimp 2.8.20-1.1.

References

Show 23 moreShow less
MoveEnter Open