CVE-2017-18184
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the...
CVE-2017-18184 is a medium vulnerability (CVSS 5.5) in Qpdf Project Qpdf, published February 13, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.67%, the 51st percentile. Fixed in qpdf 7.0.0-1.
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
- Record
CVE-2017-18184- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
- Record
CVE-2017-18184- Updated
- 2026-11-02
EUVDEUVD-2017-9319 No score
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
- Record
EUVD-2017-9319- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f5x9-mwv6-rmv7
5.5
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the...
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
- Record
GHSA-f5x9-mwv6-rmv7- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
5.5
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
- Record
CVE-2017-18184- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-18184
5.5
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
- Record
DEBIAN-CVE-2017-18184- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-18184
5.5
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
- Record
UBUNTU-CVE-2017-18184- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-3638-1 No score
qpdf vulnerabilities
It was discovered that QPDF incorrectly handled certain malformed files. A remote attacker could use this issue to cause QPDF to crash, resulting in a denial of service, or possibly execute arbitrary code.
- Record
USN-3638-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
qpdfDebian:12 |
before 7.0.0-1 | 7.0.0-1 |
qpdfDebian:13 |
before 7.0.0-1 | 7.0.0-1 |
qpdfDebian:14 |
before 7.0.0-1 | 7.0.0-1 |
qpdfUbuntu:14.04:LTS |
before 8.0.2-3~14.04.1, plus listed versions 4.2.0-25.0.1-15.0.1-1ubuntu15.1.0-15.1.1-1 |
8.0.2-3~14.04.1 |
qpdfUbuntu:16.04:LTS |
before 8.0.2-3~16.04.1, plus listed versions 5.1.3-25.1.3-35.2.0-15.2.0-26.0.0-2 |
8.0.2-3~16.04.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
usn.ubuntu.com/3638-1
github.com/qpdf/qpdf/commit/dea704f0ab7f625e1e7b3f9a1110b45b63157317
github.com/qpdf/qpdf/issues/147
nvd.nist.gov/vuln/detail/CVE-2017-18184
github.com/advisories/GHSA-f5x9-mwv6-rmv7
security-tracker.debian.org/tracker/CVE-2017-18184
Show 16 moreShow less
ubuntu.com/security/CVE-2017-18184
ubuntu.com/security/notices/USN-3638-1
cve.org/CVERecord?id=CVE-2017-18184
ubuntu.com/security/CVE-2015-9252
ubuntu.com/security/CVE-2017-9208
ubuntu.com/security/CVE-2017-9209
ubuntu.com/security/CVE-2017-9210
ubuntu.com/security/CVE-2017-11624
ubuntu.com/security/CVE-2017-11625
ubuntu.com/security/CVE-2017-11626
ubuntu.com/security/CVE-2017-11627
ubuntu.com/security/CVE-2017-12595
ubuntu.com/security/CVE-2017-18183
ubuntu.com/security/CVE-2017-18185
ubuntu.com/security/CVE-2017-18186
ubuntu.com/security/CVE-2018-9918