Every CVE Search/ Get API key

CVE-2017-18266

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before...

8.8 HighFix available

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.40%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.

Record
CVE-2017-18266
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-74
Updated
2026-11-02
CVE List No score

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.

Record
CVE-2017-18266
Updated
2026-11-02
EUVDEUVD-2017-9393 No score

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.

Record
EUVD-2017-9393
Updated
2026-11-03
GitHub AdvisoriesGHSA-76r6-j2q8-m63q 8.8

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before...

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.

Record
GHSA-76r6-j2q8-m63q
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-74
Updated
2026-11-02
OSV 8.8

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.

Record
CVE-2017-18266
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-18266 8.8

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.

Record
DEBIAN-CVE-2017-18266
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2017-18266 8.8

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.

Record
UBUNTU-CVE-2017-18266
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0289 No score

Updated xdg-utils package fixes security vulnerability

Updated xdg-utils package fixes security vulnerability:

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable (CVE-2017-18266).

Record
MGASA-2018-0289
Updated
2026-11-02
OSVopenSUSE-SU-2024:11518-1 No score

xdg-utils-1.1.3+20201113-1.2 on GA media

These are all security issues fixed in the xdg-utils-1.1.3+20201113-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11518-1
Updated
2026-11-02
OSVSUSE-SU-2018:1497-1 No score

Security update for xdg-utils

This update for xdg-utils fixes the following issues:

Security issue:

  • CVE-2017-18266: Fix an argument injection when BROWSER contains %s (bsc#1093086).
Record
SUSE-SU-2018:1497-1
Updated
2026-11-02
OSVUSN-3650-1 No score

xdg-utils vulnerability

It was discovered that xdg-utils incorrectly handled certain inputs. An attacker could possibly use this to execute arbitrary code.

Record
USN-3650-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xdg-utils
Debian:12
before 1.1.3-1
1.1.3-1
xdg-utils
Debian:13
before 1.1.3-1
1.1.3-1
xdg-utils
Debian:14
before 1.1.3-1
1.1.3-1
xdg-utils
Debian:7
before 1.1.0~rc1+git20111210-6+deb7u4, plus listed versions
1.1.0~rc1+git20111210-61.1.0~rc1+git20111210-6+deb7u11.1.0~rc1+git20111210-6+deb7u21.1.0~rc1+git20111210-6+deb7u3
1.1.0~rc1+git20111210-6+deb7u4
xdg-utils
Debian:8
before 1.1.0~rc1+git20111210-7.4+deb8u1, plus listed versions
1.1.0~rc1+git20111210-7.4
1.1.0~rc1+git20111210-7.4+deb8u1
xdg-utils
Debian:9
before 1.1.1-1+deb9u1, plus listed versions
1.1.1-1
1.1.1-1+deb9u1
xdg-utils
Mageia:6
before 1.1.3-1.mga6
1.1.3-1.mga6
xdg-utils
SUSE:Linux Enterprise Desktop 12 SP3
before 20140630-6.3.1
20140630-6.3.1
xdg-utils
SUSE:Linux Enterprise Server 12 SP3
before 20140630-6.3.1
20140630-6.3.1
xdg-utils
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 20140630-6.3.1
20140630-6.3.1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
xdg-utils
Ubuntu:14.04:LTS
before 1.1.0~rc1-2ubuntu7.2, plus listed versions
1.1.0~rc1-2ubuntu71.1.0~rc1-2ubuntu7.1
1.1.0~rc1-2ubuntu7.2
xdg-utils
Ubuntu:16.04:LTS
before 1.1.1-1ubuntu1.16.04.3, plus listed versions
1.1.0~rc3+git20150907-1ubuntu21.1.0~rc3+git20150907-1ubuntu31.1.1-1ubuntu11.1.1-1ubuntu1.16.04.1
1.1.1-1ubuntu1.16.04.3
xdg-utils
Ubuntu:18.04:LTS
before 1.1.2-1ubuntu2.2, plus listed versions
1.1.1-1ubuntu21.1.1-1ubuntu31.1.2-1ubuntu11.1.2-1ubuntu2
1.1.2-1ubuntu2.2
xdg-utils
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 1.1.3+20201113-1.2
1.1.3+20201113-1.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-18266 is a high vulnerability (CVSS 8.8) in Freedesktop Xdg-utils, published May 10, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.40%, the 84th percentile. Fixed in xdg-utils 1.1.3-1.

References

Show 14 moreShow less
MoveEnter Open