Every CVE Search/ Get API key

CVE-2017-18359

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of...

7.5 HighFix available

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.05%Up 1.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.

Record
CVE-2017-18359
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.

Record
CVE-2017-18359
Updated
2026-11-02
EUVDEUVD-2017-9478 No score

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.

Record
EUVD-2017-9478
Updated
2026-11-03
GitHub AdvisoriesGHSA-6f64-6j5j-jvvx 7.5

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of...

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.

Record
GHSA-6f64-6j5j-jvvx
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 7.5

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.

Record
CVE-2017-18359
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-18359 7.5

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.

Record
DEBIAN-CVE-2017-18359
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-18359 7.5

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.

Record
UBUNTU-CVE-2017-18359
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2022:10042-1 No score

Security update for librttopo

This update for librttopo fixes the following issues:

  • CVE-2017-18359: Fixed a denial of service in rtgeom_to_x3d3() (boo#1201215)
Record
openSUSE-SU-2022:10042-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:12171-1 No score

librttopo-devel-1.1.0-2.1 on GA media

These are all security issues fixed in the librttopo-devel-1.1.0-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12171-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postgis
Debian:12
before 2.3.3+dfsg-1
2.3.3+dfsg-1
postgis
Debian:13
before 2.3.3+dfsg-1
2.3.3+dfsg-1
postgis
Debian:14
before 2.3.3+dfsg-1
2.3.3+dfsg-1
postgis
Debian:8
before 2.1.4+dfsg-3+deb8u1, plus listed versions
2.1.4+dfsg-3
2.1.4+dfsg-3+deb8u1
postgis
Debian:9
before 2.3.1+dfsg-2+deb9u1, plus listed versions
2.3.1+dfsg-2
2.3.1+dfsg-2+deb9u1
postgis
Ubuntu:14.04:LTS
before 2.1.2+dfsg-2ubuntu0.2, plus listed versions
1.5.3-2ubuntu12.1.0-42.1.1-12.1.1-22.1.1-3
Show 4 moreShow less
2.1.1-42.1.1-52.1.2+dfsg-22.1.2+dfsg-2ubuntu0.1
2.1.2+dfsg-2ubuntu0.2
postgis
Ubuntu:16.04:LTS
before 2.2.1+dfsg-2ubuntu0.1, plus listed versions
2.1.8+dfsg-42.2.0+dfsg-12.2.0+dfsg-32.2.1+dfsg-12.2.1+dfsg-2
2.2.1+dfsg-2ubuntu0.1
librttopo
SUSE:Package Hub 15 SP4
before 1.1.0-bp154.2.3.1
1.1.0-bp154.2.3.1
librttopo
openSUSE:Leap 15.4
before 1.1.0-bp154.2.3.1
1.1.0-bp154.2.3.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-18359 is a high vulnerability (CVSS 7.5) in Postgis, published January 25, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.05%, the 87th percentile. Fixed in postgis 2.3.3+dfsg-1.

References

Show 7 moreShow less
MoveEnter Open