CVE-2017-2292
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load,...
CVE-2017-2292 is a critical vulnerability (CVSS 9.0) in Puppet Mcollective, published June 30, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.18%, the 82nd percentile. Fixed in mcollective 2.12.0+dfsg-1.
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
NVD Score used
9.0
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.
- Record
CVE-2017-2292- CVSS 3.0
- 9.0 Critical
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-502
- Updated
- 2026-11-02
CVE List No score
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.
- Record
CVE-2017-2292- Updated
- 2026-11-02
EUVDEUVD-2017-11475 No score
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.
- Record
EUVD-2017-11475- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9hgj-f7f3-cph7
9.0
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load,...
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.
- Record
GHSA-9hgj-f7f3-cph7- CVSS 3.0
- 9.0 Critical
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L - Weakness
- CWE-502
- Updated
- 2026-11-02
OSV
9.0
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.
- Record
CVE-2017-2292- CVSS 3.0
- 9.0 Critical
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L - Updated
- 2026-11-03
OSVDEBIAN-CVE-2017-2292
9.0
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.
- Record
DEBIAN-CVE-2017-2292- CVSS 3.0
- 9.0 Critical
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-2292
9.0
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.
- Record
UBUNTU-CVE-2017-2292- CVSS 3.0
- 9.0 Critical
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mcollectiveDebian:12 |
before 2.12.0+dfsg-1 | 2.12.0+dfsg-1 |
mcollectiveUbuntu:16.04:LTS |
All versions, plus listed versions 2.6.0+dfsg-2.1 |
None known |
mcollectiveUbuntu:18.04:LTS |
All versions, plus listed versions 2.6.0+dfsg-2.1 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
puppet.com/security/cve/cve-2017-2292
security.gentoo.org/glsa/201709-01
nvd.nist.gov/vuln/detail/CVE-2017-2292
github.com/advisories/GHSA-9hgj-f7f3-cph7
security-tracker.debian.org/tracker/CVE-2017-2292
ubuntu.com/security/CVE-2017-2292
github.com/puppetlabs/marionette-collective/commit/e0e741889f5adeb8f75387037106b0d28a9099b0
cve.org/CVERecord?id=CVE-2017-2292