Every CVE Search/ Get API key

CVE-2017-2576

Moodle Incorrect sanitation of attributes in forums

5.3 MediumFix available

In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

1.01%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.3

In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.

Record
CVE-2017-2576
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.

Record
CVE-2017-2576
Updated
2026-11-02
EUVDEUVD-2022-3590 No score

In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.

Record
EUVD-2022-3590
Updated
2026-11-03
GitHub AdvisoriesGHSA-cjrf-xg77-chpw 5.3

Moodle Incorrect sanitation of attributes in forums

In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.

Record
GHSA-cjrf-xg77-chpw
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-20
Updated
2026-11-02
OSV 5.3

In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.

Record
CVE-2017-2576
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVGHSA-cjrf-xg77-chpw 5.3

Moodle Incorrect sanitation of attributes in forums

In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.

Record
GHSA-cjrf-xg77-chpw
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-20
Updated
2026-11-02
OSVUBUNTU-CVE-2017-2576 5.3

In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.

Record
UBUNTU-CVE-2017-2576
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
2.7 up to 2.7.18
2.7.18
moodle/moodle
Packagist
3.0 up to 3.0.8
3.0.8
moodle/moodle
Packagist
3.1 up to 3.1.4
3.1.4
moodle/moodle
Packagist
3.2 up to 3.2.1
3.2.1
moodle/moodle
Packagist
2.7 up to 2.7.18, plus listed versions
v2.7.0v2.7.0-betav2.7.0-rc1v2.7.0-rc2v2.7.1
Show 16 moreShow less
v2.7.10v2.7.11v2.7.12v2.7.13v2.7.14v2.7.15v2.7.16v2.7.17v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6v2.7.7v2.7.8v2.7.9
2.7.18
moodle/moodle
Packagist
3.0 up to 3.0.8, plus listed versions
v3.0.0v3.0.0-betav3.0.0-rc1v3.0.0-rc2v3.0.0-rc3
Show 8 moreShow less
v3.0.0-rc4v3.0.1v3.0.2v3.0.3v3.0.4v3.0.5v3.0.6v3.0.7
3.0.8
moodle/moodle
Packagist
3.1 up to 3.1.4, plus listed versions
v3.1.0v3.1.0-betav3.1.0-rc1v3.1.0-rc2v3.1.1v3.1.2v3.1.3
3.1.4
moodle/moodle
Packagist
3.2 up to 3.2.1, plus listed versions
v3.2.0v3.2.0-betav3.2.0-rc1v3.2.0-rc2v3.2.0-rc3v3.2.0-rc4v3.2.0-rc5
3.2.1
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-2576 is a medium vulnerability (CVSS 5.3) in Moodle, published January 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in moodle/moodle 2.7.18.

References

MoveEnter Open