CVE-2017-2810
Loaded Databook of Tablib prone to python insertion resulting in command execution
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
- Record
CVE-2017-2810- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
EUVDEUVD-2017-0134
7.5
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
- Record
EUVD-2017-0134- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gcr6-rf47-jrgf
9.3
Loaded Databook of Tablib prone to python insertion resulting in command execution
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
- Record
GHSA-gcr6-rf47-jrgf- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
NVD
7.5
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
- Record
CVE-2017-2810- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
OSV
9.8
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
- Record
CVE-2017-2810- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-2810
9.8
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
- Record
DEBIAN-CVE-2017-2810- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-gcr6-rf47-jrgf
9.3
Loaded Databook of Tablib prone to python insertion resulting in command execution
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
- Record
GHSA-gcr6-rf47-jrgf- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-2810
9.8
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
- Record
UBUNTU-CVE-2017-2810- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVPYSEC-2017-95 No score
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
- Record
PYSEC-2017-95- Updated
- 2026-11-02
OSVSUSE-SU-2017:2105-1 No score
Security update for python-tablib
This update for python-tablib fixes the following issues:
- CVE-2017-2810: Use yaml.safe_load and yaml.safe_dump to avoid executing code when importing data (bsc#1044329)
- Record
SUSE-SU-2017:2105-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
tablibPyPI |
before 0.11.5 | 0.11.5 |
python-tablibDebian:12 |
before 0.9.11-3 | 0.9.11-3 |
python-tablibDebian:13 |
before 0.9.11-3 | 0.9.11-3 |
python-tablibDebian:14 |
before 0.9.11-3 | 0.9.11-3 |
tablibPyPI |
before 0.11.5, plus listed versions 0.0.10.10.00.11.00.11.10.11.2 Show 25 moreShow less0.11.30.11.40.6.10.6.20.6.30.6.40.7.00.7.10.8.00.8.10.8.20.8.30.8.40.9.00.9.10.9.100.9.110.9.20.9.30.9.40.9.50.9.60.9.70.9.80.9.9 |
0.11.5 |
python-tablibSUSE:OpenStack Cloud 6 |
before 0.9.11-3.1 | 0.9.11-3.1 |
python-tablibSUSE:OpenStack Cloud 7 |
before 0.9.11-3.1 | 0.9.11-3.1 |
python-tablibSUSE:Linux Enterprise Module for Public Cloud 12 |
before 0.9.11-3.1 | 0.9.11-3.1 |
python-tablibUbuntu:16.04:LTS |
before 0.9.11-2+deb9u1build0.16.04.1, plus listed versions 0.9.11-2build1 |
0.9.11-2+deb9u1build0.16.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-2810 is a high vulnerability (CVSS 7.5) in Kenneth Reitz Tablib, published June 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.87%, the 92nd percentile. Fixed in tablib 0.11.5.
References
securityfocus.com/bid/99076
security.gentoo.org/glsa/201811-18
talosintelligence.com/vulnerability_reports/TALOS-2017-0307
nvd.nist.gov/vuln/detail/CVE-2017-2810
github.com/jazzband/tablib/commit/69abfc3ada5d754cb152119c0b4777043657cb6e
github.com/advisories/GHSA-gcr6-rf47-jrgf
Show 8 moreShow less
github.com/pypa/advisory-database/tree/main/vulns/tablib/PYSEC-2017-95.yaml
security-tracker.debian.org/tracker/CVE-2017-2810
github.com/jazzband/tablib
suse.com/support/update/announcement/2017/suse-su-20172105-1
bugzilla.suse.com/1044329
suse.com/security/cve/CVE-2017-2810
ubuntu.com/security/CVE-2017-2810
cve.org/CVERecord?id=CVE-2017-2810