Every CVE Search/ Get API key

CVE-2017-2816

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0...

8.8 HighFix available

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.39%Up 1.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 8.8

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

Record
CVE-2017-2816
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
EUVDEUVD-2017-11957 8.8

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

Record
EUVD-2017-11957
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-3w43-mhj6-r4fj 8.8

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0...

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

Record
GHSA-3w43-mhj6-r4fj
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
NVD 8.8

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

Record
CVE-2017-2816
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
OSV 8.8

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

Record
CVE-2017-2816
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-2816 8.8

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

Record
DEBIAN-CVE-2017-2816
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2017-2816 8.8

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

Record
UBUNTU-CVE-2017-2816
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0214 No score

Updated libofx packages fix security vulnerabilities

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability (CVE-2017-2816).

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability (CVE-2017-2920).

ofx_proc_file in ofx_preproc.cpp in LibOFX 0.9.12 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file, as demonstrated by an ofxdump call (CVE-2017-14731).

Record
MGASA-2018-0214
Updated
2026-11-02
OSVopenSUSE-SU-2024:10964-1 No score

libofx-0.10.1-1.9 on GA media

These are all security issues fixed in the libofx-0.10.1-1.9 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10964-1
Updated
2026-11-02
OSVSUSE-SU-2018:2045-1 No score

Security update for libofx

This update for libofx fixes the following issues:

Security issues fixed:

  • CVE-2017-2816: Fix an exploitable buffer overflow vulnerability in the tag parsing functionality (bsc#1058673).
  • CVE-2017-2920: Fix a buffer overflow vulnerability in sanitize_proprietary_tags in lib/ofx_preproc.cpp (bsc#1061964).
  • CVE-2017-14731: Fix remote denial of service via a crafted file in ofx_proc_file in ofx_preproc.cpp (bsc#1060437).
Record
SUSE-SU-2018:2045-1
Updated
2026-11-02
OSVSUSE-SU-2018:2064-1 No score

Security update for libofx

This update for libofx fixes the following issues:

Security issues fixed:

  • CVE-2017-2816: Fix an exploitable buffer overflow vulnerability in the tag parsing functionality (bsc#1058673).
  • CVE-2017-2920: Fix a buffer overflow vulnerability in sanitize_proprietary_tags in lib/ofx_preproc.cpp (bsc#1061964).
  • CVE-2017-14731: Fix remote denial of service via a crafted file in ofx_proc_file in ofx_preproc.cpp (bsc#1060437).
Record
SUSE-SU-2018:2064-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libofx
Debian:12
before 1:0.9.11-4
1:0.9.11-4
libofx
Debian:13
before 1:0.9.11-4
1:0.9.11-4
libofx
Debian:14
before 1:0.9.11-4
1:0.9.11-4
libofx
Debian:7
before 1:0.9.4-2.1+deb7u1, plus listed versions
1:0.9.4-2.1
1:0.9.4-2.1+deb7u1
libofx
Mageia:6
before 0.9.10-2.mga6
0.9.10-2.mga6
libofx
SUSE:Linux Enterprise Software Development Kit 11 SP4
before 0.9.0-3.7.1
0.9.0-3.7.1
libofx
SUSE:Linux Enterprise Desktop 12 SP3
before 0.9.9-3.7.1
0.9.9-3.7.1
libofx
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 0.9.9-3.7.1
0.9.9-3.7.1
libofx
SUSE:Linux Enterprise Workstation Extension 12 SP3
before 0.9.9-3.7.1
0.9.9-3.7.1
libofx
Ubuntu:16.04:LTS
before 1:0.9.10-1+deb8u1build0.16.04.1, plus listed versions
1:0.9.10-1build2
1:0.9.10-1+deb8u1build0.16.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-2816 is a high vulnerability (CVSS 8.8) in Libofx, published September 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.39%, the 84th percentile. Fixed in libofx 1:0.9.11-4.

References

Show 14 moreShow less
MoveEnter Open