Every CVE Search/ Get API key

CVE-2017-3003

Adobe Flash Player versions 24.0.0.221 and earlier have an exploitable use after free...

8.8 High

Adobe Flash Player versions 24.0.0.221 and earlier have an exploitable use after free vulnerability related to an interaction between the privacy user interface and the ActionScript 2 Camera object. Successful exploitation could lead to arbitrary code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

5.25%Down 4.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Adobe Flash Player versions 24.0.0.221 and earlier have an exploitable use after free vulnerability related to an interaction between the privacy user interface and the ActionScript 2 Camera object. Successful exploitation could lead to arbitrary code execution.

Record
CVE-2017-3003
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-416
Updated
2026-11-02
CVE List No score

Adobe Flash Player versions 24.0.0.221 and earlier have an exploitable use after free vulnerability related to an interaction between the privacy user interface and the ActionScript 2 Camera object. Successful exploitation could lead to arbitrary code execution.

Record
CVE-2017-3003
Updated
2026-11-02
EUVDEUVD-2017-12144 No score

Adobe Flash Player versions 24.0.0.221 and earlier have an exploitable use after free vulnerability related to an interaction between the privacy user interface and the ActionScript 2 Camera object. Successful exploitation could lead to arbitrary code execution.

Record
EUVD-2017-12144
Updated
2026-11-03
GitHub AdvisoriesGHSA-3hf8-m65w-793g 9.8

Adobe Flash Player versions 24.0.0.221 and earlier have an exploitable use after free...

Adobe Flash Player versions 24.0.0.221 and earlier have an exploitable use after free vulnerability related to an interaction between the privacy user interface and the ActionScript 2 Camera object. Successful exploitation could lead to arbitrary code execution.

Record
GHSA-3hf8-m65w-793g
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-416
Updated
2026-11-02
OSVRHSA-2017:0526 8.8

Red Hat Security Advisory: flash-plugin security update

Record
RHSA-2017:0526
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0087 No score

Updated flash-player-plugin packages fix security vulnerability

Updated flash-player-plugin installs latest version for the flash plugin from adobe. See the referenced security bulletin for details.

Record
MGASA-2017-0087
Updated
2026-11-02
OSVSUSE-SU-2017:0703-1 No score

Security update for flash-player

This update for flash-player fixes the following issues:

Security update to 25.0.0.127 (bsc#1029374), fixing the following vulnerabilities advised under APSB17-07:

  • CVE-2017-2997: This update resolves a buffer overflow vulnerability that could lead to code execution.
  • CVE-2017-2998, CVE-2017-2999: This update resolves memory corruption vulnerabilities that could lead to code execution.
  • CVE-2017-3000: This update resolves a random number generator vulnerability used for constant blinding that could lead to information disclosure.
  • CVE-2017-3001, CVE-2017-3002, CVE-2017-3003: This update resolves use-after-free vulnerabilities that could lead to code execution.
  • Details: https://helpx.adobe.com/security/products/flash-player/apsb17-07.html
Record
SUSE-SU-2017:0703-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-player-plugin
Mageia:5
From an advisory covering 7 CVEs
before 25.0.0.127-1.mga5.nonfree
25.0.0.127-1.mga5.nonfree
flash-plugin
Red Hat:rhel_extras:6
From an advisory covering 8 CVEs
before 0:25.0.0.127-1.el6_8
0:25.0.0.127-1.el6_8
flash-player
SUSE:Linux Enterprise Desktop 12 SP1
From an advisory covering 7 CVEs
before 25.0.0.127-162.1
25.0.0.127-162.1
flash-player
SUSE:Linux Enterprise Workstation Extension 12 SP1
From an advisory covering 7 CVEs
before 25.0.0.127-162.1
25.0.0.127-162.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-3003 is a high vulnerability (CVSS 8.8) in Adobe Flash Player, published March 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.25%, the 92nd percentile. No source names a fixed version.

References

Show 39 moreShow less
MoveEnter Open