Every CVE Search/ Get API key

CVE-2017-3073

Adobe Flash Player versions 25.0.0.148 and earlier have an exploitable use after free...

8.8 HighFix available

Adobe Flash Player versions 25.0.0.148 and earlier have an exploitable use after free vulnerability when handling multiple mask properties of display objects, aka memory corruption. Successful exploitation could lead to arbitrary code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.86%Down 2.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Adobe Flash Player versions 25.0.0.148 and earlier have an exploitable use after free vulnerability when handling multiple mask properties of display objects, aka memory corruption. Successful exploitation could lead to arbitrary code execution.

Record
CVE-2017-3073
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-416
Updated
2026-11-02
CVE List No score

Adobe Flash Player versions 25.0.0.148 and earlier have an exploitable use after free vulnerability when handling multiple mask properties of display objects, aka memory corruption. Successful exploitation could lead to arbitrary code execution.

Record
CVE-2017-3073
Updated
2026-11-02
EUVDEUVD-2017-12214 No score

Adobe Flash Player versions 25.0.0.148 and earlier have an exploitable use after free vulnerability when handling multiple mask properties of display objects, aka memory corruption. Successful exploitation could lead to arbitrary code execution.

Record
EUVD-2017-12214
Updated
2026-11-03
GitHub AdvisoriesGHSA-r88h-g29r-792h 9.8

Adobe Flash Player versions 25.0.0.148 and earlier have an exploitable use after free...

Adobe Flash Player versions 25.0.0.148 and earlier have an exploitable use after free vulnerability when handling multiple mask properties of display objects, aka memory corruption. Successful exploitation could lead to arbitrary code execution.

Record
GHSA-r88h-g29r-792h
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-416
Updated
2026-11-02
OSVRHSA-2017:1219 8.8

Red Hat Security Advisory: flash-plugin security update

Record
RHSA-2017:1219
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-3073 8.8

Adobe Flash Player versions 25.0.0.148 and earlier have an exploitable use after free vulnerability when handling multiple mask properties of display objects, aka memory corruption. Successful exploitation could lead to arbitrary code execution.

Record
UBUNTU-CVE-2017-3073
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0143 No score

Updated flash-player-plugin packages fix security vulnerability

Adobe Flash Player 25.0.0.171 contains fixes to critical security vulnerabilities found in earlier versions that could potentially allow an attacker to take control of the affected system.

This updates resolves a use-after-free vulnerability that could lead to code execution (CVE-2017-3071).

This updates resolves memory corruption vulnerabilities that could lead to code execution (CVE-2017-3068, CVE-2017-3069, CVE-2017-3070, CVE-2017-3072, CVE-2017-3073, CVE-2017-3074).

Record
MGASA-2017-0143
Updated
2026-11-02
OSVSUSE-SU-2017:1238-1 No score

Security update for flash-player

This update for flash-player fixes the following issues:

  • Security update to 25.0.0.171 (bsc#1038281), fixing the following vulnerabilities advised under APSB17-15:
Record
SUSE-SU-2017:1238-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-player-plugin
Mageia:5
before 25.0.0.171-1.mga5.nonfree
25.0.0.171-1.mga5.nonfree
flash-plugin
Red Hat:rhel_extras:6
before 0:25.0.0.171-1.el6_9
0:25.0.0.171-1.el6_9
flash-player
SUSE:Linux Enterprise Desktop 12 SP1
before 25.0.0.171-168.1
25.0.0.171-168.1
flash-player
SUSE:Linux Enterprise Workstation Extension 12 SP1
before 25.0.0.171-168.1
25.0.0.171-168.1
flashplugin-nonfree
Ubuntu:14.04:LTS
before 25.0.0.171ubuntu0.14.04.1, plus listed versions
11.2.202.310ubuntu111.2.202.327ubuntu0.13.10.111.2.202.332ubuntu111.2.202.335ubuntu111.2.202.336ubuntu1
Show 45 moreShow less
11.2.202.341ubuntu111.2.202.346ubuntu111.2.202.350ubuntu111.2.202.356ubuntu0.14.04.111.2.202.359ubuntu0.14.04.111.2.202.378ubuntu0.14.04.111.2.202.394ubuntu0.14.04.111.2.202.400ubuntu0.14.04.111.2.202.406ubuntu0.14.04.111.2.202.406ubuntu0.14.04.211.2.202.411ubuntu0.14.04.111.2.202.418ubuntu0.14.04.111.2.202.424ubuntu0.14.04.111.2.202.425ubuntu0.14.04.111.2.202.429ubuntu0.14.04.111.2.202.438ubuntu0.14.04.111.2.202.440ubuntu0.14.04.111.2.202.442ubuntu0.14.04.111.2.202.451ubuntu0.14.04.111.2.202.457ubuntu0.14.04.111.2.202.460ubuntu0.14.04.111.2.202.466ubuntu0.14.04.111.2.202.468ubuntu0.14.04.111.2.202.481ubuntu0.14.04.111.2.202.481ubuntu0.14.04.211.2.202.491ubuntu0.14.04.111.2.202.508ubuntu0.14.04.111.2.202.521ubuntu0.14.04.111.2.202.535ubuntu0.14.04.111.2.202.540ubuntu0.14.04.211.2.202.548ubuntu0.14.04.111.2.202.554ubuntu0.14.04.111.2.202.559ubuntu0.14.04.111.2.202.569ubuntu0.14.04.111.2.202.577ubuntu0.14.04.111.2.202.616ubuntu0.14.04.111.2.202.621ubuntu0.14.04.111.2.202.626ubuntu0.14.04.111.2.202.632ubuntu0.14.04.111.2.202.635ubuntu0.14.04.111.2.202.637ubuntu0.14.04.111.2.202.643ubuntu0.14.04.111.2.202.644ubuntu0.14.04.124.0.0.186ubuntu0.14.04.124.0.0.194ubuntu0.14.04.1
25.0.0.171ubuntu0.14.04.1
flashplugin-nonfree
Ubuntu:16.04:LTS
before 25.0.0.171ubuntu0.16.04.1, plus listed versions
11.2.202.540ubuntu211.2.202.548ubuntu111.2.202.554ubuntu111.2.202.559ubuntu111.2.202.569ubuntu1
Show 14 moreShow less
11.2.202.577ubuntu111.2.202.616ubuntu111.2.202.621ubuntu0.16.04.111.2.202.626ubuntu0.16.04.111.2.202.632ubuntu0.16.04.111.2.202.635ubuntu0.16.04.111.2.202.637ubuntu0.16.04.111.2.202.643ubuntu0.16.04.111.2.202.644ubuntu0.16.04.124.0.0.186ubuntu0.16.04.124.0.0.194ubuntu0.16.04.124.0.0.221ubuntu0.16.04.125.0.0.127ubuntu0.16.04.125.0.0.148ubuntu0.16.04.1
25.0.0.171ubuntu0.16.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-3073 is a high vulnerability (CVSS 8.8) in Adobe Flash Player, published May 9, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.86%, the 92nd percentile. Fixed in flash-player-plugin 25.0.0.171-1.mga5.nonfree.

References

Show 36 moreShow less
This page doesn't list everything

Left out here: 3 versions. The JSON record has them.

MoveEnter Open