Every CVE Search/ Get API key

CVE-2017-3162

Improper Input Validation in Apache Hadoop

7.3 HighFix available

HDFS clients interact with a servlet on the DataNode to browse the HDFS namespace. The NameNode is provided as a query parameter that is not validated in Apache Hadoop before 2.7.0.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

6.42%Up 4.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.3

HDFS clients interact with a servlet on the DataNode to browse the HDFS namespace. The NameNode is provided as a query parameter that is not validated in Apache Hadoop before 2.7.0.

Record
CVE-2017-3162
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

HDFS clients interact with a servlet on the DataNode to browse the HDFS namespace. The NameNode is provided as a query parameter that is not validated in Apache Hadoop before 2.7.0.

Record
CVE-2017-3162
Updated
2026-11-02
EUVDEUVD-2022-4816 No score

HDFS clients interact with a servlet on the DataNode to browse the HDFS namespace. The NameNode is provided as a query parameter that is not validated in Apache Hadoop before 2.7.0.

Record
EUVD-2022-4816
Updated
2026-11-03
GitHub AdvisoriesGHSA-pr9x-qmp5-j3rr 7.3

Improper Input Validation in Apache Hadoop

HDFS clients interact with a servlet on the DataNode to browse the HDFS namespace. The NameNode is provided as a query parameter that is not validated in Apache Hadoop before 2.7.0.

Record
GHSA-pr9x-qmp5-j3rr
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
OSV 7.3

HDFS clients interact with a servlet on the DataNode to browse the HDFS namespace. The NameNode is provided as a query parameter that is not validated in Apache Hadoop before 2.7.0.

Record
CVE-2017-3162
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
OSVGHSA-pr9x-qmp5-j3rr 7.3

Improper Input Validation in Apache Hadoop

HDFS clients interact with a servlet on the DataNode to browse the HDFS namespace. The NameNode is provided as a query parameter that is not validated in Apache Hadoop before 2.7.0.

Record
GHSA-pr9x-qmp5-j3rr
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.hadoop:hadoop-client
Maven
through 2.6.5
2.7.0
org.apache.hadoop:hadoop-client
Maven
before 2.7.0, plus listed versions
0.23.10.23.100.23.110.23.30.23.4
Show 36 moreShow less
0.23.50.23.60.23.70.23.80.23.91.0.11.0.21.0.31.0.41.1.01.1.11.1.21.2.01.2.12.0.0-alpha2.0.1-alpha2.0.2-alpha2.0.3-alpha2.0.4-alpha2.0.5-alpha2.0.6-alpha2.1.0-beta2.1.1-beta2.2.02.3.02.4.02.4.12.5.02.5.12.5.22.6.02.6.12.6.22.6.32.6.42.6.5
2.7.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-3162 is a high vulnerability (CVSS 7.3) in Apache Hadoop, published April 26, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.42%, the 93rd percentile. Fixed in org.apache.hadoop:hadoop-client 2.7.0.

References

MoveEnter Open