Every CVE Search/ Get API key

CVE-2017-5356

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and...

7.5 HighFix available

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

4.78%Up 2.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).

Record
CVE-2017-5356
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).

Record
CVE-2017-5356
Updated
2026-11-02
EUVDEUVD-2017-14460 No score

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).

Record
EUVD-2017-14460
Updated
2026-11-03
GitHub AdvisoriesGHSA-rxfr-9cmv-jwxm 7.5

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and...

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).

Record
GHSA-rxfr-9cmv-jwxm
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVALPINE-CVE-2017-5356 7.5

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).

Record
ALPINE-CVE-2017-5356
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).

Record
CVE-2017-5356
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2017-5356 7.5

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).

Record
DEBIAN-CVE-2017-5356
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-5356 7.5

Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).

Record
UBUNTU-CVE-2017-5356
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2017-0018 No score

Updated irssi packages fix security vulnerabilities

In irssi before 0.8.21, a NULL pointer dereference in the nickcmp function (CVE-2017-5193).

In irssi before 0.8.21, use after free when receiving invalid nick message (CVE-2017-5194).

In irssi before 0.8.21, out of bounds read in certain incomplete control codes (CVE-2017-5195).

In irssi before 0.8.21, out of bounds read in certain incomplete character sequences (CVE-2017-5196).

In irssi before 0.8.21, out of bounds read when printing certain values (CVE-2017-5356).

Record
MGASA-2017-0018
Updated
2026-11-02
OSVopenSUSE-SU-2024:10865-1 No score

irssi-1.2.3-2.4 on GA media

These are all security issues fixed in the irssi-1.2.3-2.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10865-1
Updated
2026-11-02
OSVUSN-3184-1 No score

irssi vulnerabilities

It was discovered that the Irssi buf.pl script set incorrect permissions. A local attacker could use this issue to retrieve another user's window contents. (CVE-2016-7553)

Joseph Bisch discovered that Irssi incorrectly handled comparing nicks. A remote attacker could use this issue to cause Irssi to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2017-5193)

It was discovered that Irssi incorrectly handled invalid nick messages. A remote attacker could use this issue to cause Irssi to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2017-5194)

Joseph Bisch discovered that Irssi incorrectly handled certain incomplete control codes. A remote attacker could use this issue to cause Irssi to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 16.04 LTS and Ubuntu 16.10. (CVE-2017-5195)

Hanno Böck and Joseph Bisch discovered that Irssi incorrectly handled certain incomplete character sequences. A remote attacker could use this issue to cause Irssi to crash, resulting in a denial of service. This issue only affected Ubuntu 16.04 LTS and Ubuntu 16.10. (CVE-2017-5196)

Hanno Böck discovered that Irssi incorrectly handled certain format strings. A remote attacker could use this issue to cause Irssi to crash, resulting in a denial of service. (CVE-2017-5356)

Record
USN-3184-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
irssi
Alpine:v3.2
before 0.8.21-r0
0.8.21-r0
irssi
Alpine:v3.3
before 0.8.21-r0
0.8.21-r0
irssi
Alpine:v3.4
before 0.8.21-r0
0.8.21-r0
irssi
Alpine:v3.5
before 0.8.21-r0
0.8.21-r0
irssi
Debian:12
before 0.8.21-1
0.8.21-1
irssi
Debian:13
before 0.8.21-1
0.8.21-1
irssi
Debian:14
before 0.8.21-1
0.8.21-1
irssi
Debian:7
before 0.8.15-5+deb7u4, plus listed versions
0.8.15-50.8.15-5+deb7u10.8.15-5+deb7u20.8.15-5+deb7u3
0.8.15-5+deb7u4
irssi
Mageia:5
before 0.8.21-1.mga5
0.8.21-1.mga5
irssi
Ubuntu:14.04:LTS
before 0.8.15-5ubuntu3.1, plus listed versions
0.8.15-5ubuntu20.8.15-5ubuntu3
0.8.15-5ubuntu3.1
irssi
Ubuntu:16.04:LTS
before 0.8.19-1ubuntu1.3, plus listed versions
0.8.17-1ubuntu10.8.17-1ubuntu20.8.18-1ubuntu10.8.19-1ubuntu10.8.19-1ubuntu1.2
0.8.19-1ubuntu1.3
irssi
openSUSE:Tumbleweed
before 1.2.3-2.4
1.2.3-2.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-5356 is a high vulnerability (CVSS 7.5) in Irssi, published January 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.78%, the 91st percentile. Fixed in irssi 0.8.21-r0.

References

Show 41 moreShow less
MoveEnter Open