Every CVE Search/ Get API key

CVE-2017-5522

Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5,...

9.8 CriticalFix available

Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5, and 7.0.x before 7.0.4 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via vectors involving WFS get feature requests.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.76%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5, and 7.0.x before 7.0.4 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via vectors involving WFS get feature requests.

Record
CVE-2017-5522
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5, and 7.0.x before 7.0.4 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via vectors involving WFS get feature requests.

Record
CVE-2017-5522
Updated
2026-11-02
EUVDEUVD-2017-14626 No score

Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5, and 7.0.x before 7.0.4 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via vectors involving WFS get feature requests.

Record
EUVD-2017-14626
Updated
2026-11-03
GitHub AdvisoriesGHSA-959f-7f6r-rgh6 9.8

Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5,...

Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5, and 7.0.x before 7.0.4 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via vectors involving WFS get feature requests.

Record
GHSA-959f-7f6r-rgh6
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 9.8

Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5, and 7.0.x before 7.0.4 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via vectors involving WFS get feature requests.

Record
CVE-2017-5522
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-5522 9.8

Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5, and 7.0.x before 7.0.4 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via vectors involving WFS get feature requests.

Record
DEBIAN-CVE-2017-5522
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-5522 9.8

Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5, and 7.0.x before 7.0.4 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via vectors involving WFS get feature requests.

Record
UBUNTU-CVE-2017-5522
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mapserver
Debian:12
before 7.0.4-1
7.0.4-1
mapserver
Debian:13
before 7.0.4-1
7.0.4-1
mapserver
Debian:14
before 7.0.4-1
7.0.4-1
mapserver
Debian:7
before 6.0.1-3.2+deb7u4, plus listed versions
6.0.1-3.26.0.1-3.2+deb7u16.0.1-3.2+deb7u26.0.1-3.2+deb7u3
6.0.1-3.2+deb7u4
mapserver
Debian:8
before 6.4.1-5+deb8u3, plus listed versions
6.4.1-56.4.1-5+deb8u16.4.1-5+deb8u2
6.4.1-5+deb8u3
mapserver
Ubuntu:14.04:LTS
before 6.4.1-2ubuntu0.1, plus listed versions
6.2.1-36.4.0-26.4.0-3build16.4.1-16.4.1-1build16.4.1-2
6.4.1-2ubuntu0.1
mapserver
Ubuntu:16.04:LTS
before 7.0.0-9ubuntu3.1, plus listed versions
7.0.0-4build17.0.0-5ubuntu17.0.0-77.0.0-87.0.0-8build1
Show 4 moreShow less
7.0.0-97.0.0-9ubuntu17.0.0-9ubuntu27.0.0-9ubuntu3
7.0.0-9ubuntu3.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-5522 is a critical vulnerability (CVSS 9.8) in Osgeo Mapserver, published January 19, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.76%, the 91st percentile. Fixed in mapserver 7.0.4-1.

References

Show 6 moreShow less
MoveEnter Open