Every CVE Search/ Get API key

CVE-2017-5616

Cross-site scripting (XSS) vulnerability in cgiemail and cgiecho allows remote attackers to...

6.1 MediumFix available

Cross-site scripting (XSS) vulnerability in cgiemail and cgiecho allows remote attackers to inject arbitrary web script or HTML via the addendum parameter.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.17%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

Cross-site scripting (XSS) vulnerability in cgiemail and cgiecho allows remote attackers to inject arbitrary web script or HTML via the addendum parameter.

Record
CVE-2017-5616
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in cgiemail and cgiecho allows remote attackers to inject arbitrary web script or HTML via the addendum parameter.

Record
CVE-2017-5616
Updated
2026-11-02
EUVDEUVD-2017-14714 No score

Cross-site scripting (XSS) vulnerability in cgiemail and cgiecho allows remote attackers to inject arbitrary web script or HTML via the addendum parameter.

Record
EUVD-2017-14714
Updated
2026-11-03
GitHub AdvisoriesGHSA-253q-85fr-vjfv 6.1

Cross-site scripting (XSS) vulnerability in cgiemail and cgiecho allows remote attackers to...

Cross-site scripting (XSS) vulnerability in cgiemail and cgiecho allows remote attackers to inject arbitrary web script or HTML via the addendum parameter.

Record
GHSA-253q-85fr-vjfv
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2017-5616 6.1

Cross-site scripting (XSS) vulnerability in cgiemail and cgiecho allows remote attackers to inject arbitrary web script or HTML via the addendum parameter.

Record
UBUNTU-CVE-2017-5616
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cgiemail
Debian:7
before 1.6-37+deb7u1, plus listed versions
1.6-37
1.6-37+deb7u1
cgiemail
Ubuntu:14.04:LTS
before 1.6-37+deb7u1build0.14.04.1, plus listed versions
1.6-37
1.6-37+deb7u1build0.14.04.1
cgiemail
Ubuntu:16.04:LTS
before 1.6-37+deb7u1build0.16.04.1, plus listed versions
1.6-37
1.6-37+deb7u1build0.16.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-5616 is a medium vulnerability (CVSS 6.1) in Cpanel Cgiecho, published March 3, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.17%, the 67th percentile. Fixed in cgiemail 1.6-37+deb7u1.

References

MoveEnter Open