Every CVE Search/ Get API key

CVE-2017-5846

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins...

5.5 MediumFix available

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.03%Down 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Record
CVE-2017-5846
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Record
CVE-2017-5846
Updated
2026-11-02
EUVDEUVD-2017-14923 No score

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Record
EUVD-2017-14923
Updated
2026-11-03
GitHub AdvisoriesGHSA-c453-cjpc-84jf 5.5

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins...

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Record
GHSA-c453-cjpc-84jf
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVALPINE-CVE-2017-5846 5.5

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Record
ALPINE-CVE-2017-5846
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 5.5

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Record
CVE-2017-5846
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2017-5846 5.5

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Record
DEBIAN-CVE-2017-5846
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-5846 5.5

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Record
UBUNTU-CVE-2017-5846
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0014 No score

Updated gstreamer0.10-plugins-ugly/gstreamer1.0-plugins-ugly packages fix security vulnerability

Hanno Boeck discovered multiple vulnerabilities in the GStreamer media framework and its codecs and demuxers, which may result in denial of service or the execution of arbitrary code if a malformed media file is opened (CVE-2017-5846, CVE-2017-5847).

Record
MGASA-2018-0014
Updated
2026-11-02
OSVMGASA-2018-0015 No score

Updated gstreamer0.10-plugins-ugly packages fix security vulnerability

Hanno Boeck discovered multiple vulnerabilities in the GStreamer media framework and its codecs and demuxers, which may result in denial of service or the execution of arbitrary code if a malformed media file is opened (CVE-2017-5846, CVE-2017-5847).

Record
MGASA-2018-0015
Updated
2026-11-02
OSVopenSUSE-SU-2024:10826-1 No score

gstreamer-1.18.5-2.1 on GA media

These are all security issues fixed in the gstreamer-1.18.5-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10826-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gst-plugins-ugly
Alpine:v3.7
before 1.10.4-r0
1.10.4-r0
gst-plugins-ugly1
Alpine:v3.4
before 1.8.3-r0
1.8.3-r0
gst-plugins-ugly1
Alpine:v3.5
before 1.8.3-r0
1.8.3-r0
gst-plugins-ugly1
Alpine:v3.6
before 1.10.4-r0
1.10.4-r0
gst-plugins-ugly1.0
Debian:12
before 1.10.3-1
1.10.3-1
gst-plugins-ugly1.0
Debian:13
before 1.10.3-1
1.10.3-1
gst-plugins-ugly1.0
Debian:14
before 1.10.3-1
1.10.3-1
gst-plugins-ugly0.10
Debian:8
From an advisory covering 2 CVEs
before 0.10.19-2.1+deb8u1, plus listed versions
0.10.19-2.1
0.10.19-2.1+deb8u1
gst-plugins-ugly0.10
Debian:7
From an advisory covering 2 CVEs
before 0.10.19-2+deb7u1, plus listed versions
0.10.19-2
0.10.19-2+deb7u1
gst-plugins-ugly1.0
Debian:8
From an advisory covering 2 CVEs
before 1.4.4-2+deb8u1, plus listed versions
1.4.4-2
1.4.4-2+deb8u1
Show 9 moreShow less
Affected packages
PackageAffectedFixed
gstreamer0.10-plugins-ugly
Mageia:5
From an advisory covering 2 CVEs
before 0.10.19-14.2.mga5
0.10.19-14.2.mga5
gstreamer1.0-plugins-ugly
Mageia:5
From an advisory covering 2 CVEs
before 1.4.3-2.1.mga5
1.4.3-2.1.mga5
gstreamer0.10-plugins-ugly
Mageia:5
From an advisory covering 2 CVEs
before 0.10.19-14.2.mga5.tainted
0.10.19-14.2.mga5.tainted
gstreamer1.0-plugins-ugly
Mageia:5
From an advisory covering 2 CVEs
before 1.4.3-2.1.mga5.tainted
1.4.3-2.1.mga5.tainted
gstreamer0.10-plugins-ugly
Mageia:6
From an advisory covering 2 CVEs
before 0.10.19-18.1.mga6
0.10.19-18.1.mga6
gstreamer0.10-plugins-ugly
Mageia:6
From an advisory covering 2 CVEs
before 0.10.19-18.1.mga6.tainted
0.10.19-18.1.mga6.tainted
gst-plugins-ugly0.10
Ubuntu:14.04:LTS
before 0.10.19-2+deb7u1ubuntu0.1, plus listed versions
0.10.19-20.10.19-2ubuntu10.10.19-2ubuntu20.10.19-2ubuntu30.10.19-2ubuntu5
0.10.19-2+deb7u1ubuntu0.1
gst-plugins-ugly1.0
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
1.6.0-1ubuntu11.6.1-1ubuntu11.6.2-1ubuntu11.7.1-1ubuntu11.7.2-1ubuntu1
Show 8 moreShow less
1.7.90-1ubuntu11.7.91-1ubuntu11.8.0-1ubuntu11.8.1-1ubuntu0.11.8.2-1ubuntu0.11.8.3-1ubuntu0.11.8.3-1ubuntu0.1+esm11.8.3-1ubuntu0.1+esm2
None known
gstreamer
openSUSE:Tumbleweed
From an advisory covering 5 CVEs
before 1.18.5-2.1
1.18.5-2.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-5846 is a medium vulnerability (CVSS 5.5) in Gstreamer, published February 9, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.03%, the 81st percentile. Fixed in gst-plugins-ugly 1.10.4-r0.

References

Show 17 moreShow less
MoveEnter Open