CVE-2017-5924
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after...
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_compiler_destroy function.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_compiler_destroy function.
- Record
CVE-2017-5924- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_compiler_destroy function.
- Record
CVE-2017-5924- Updated
- 2026-11-02
EUVDEUVD-2017-14999 No score
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_compiler_destroy function.
- Record
EUVD-2017-14999- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-33qw-wpjx-355w
7.5
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after...
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_compiler_destroy function.
- Record
GHSA-33qw-wpjx-355w- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
7.5
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_compiler_destroy function.
- Record
CVE-2017-5924- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-5924
7.5
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_compiler_destroy function.
- Record
DEBIAN-CVE-2017-5924- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-5924
7.5
libyara/grammar.y in YARA 3.5.0 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted rule that is mishandled in the yr_compiler_destroy function.
- Record
UBUNTU-CVE-2017-5924- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
yaraDebian:12 |
before 3.5.0+dfsg-9 | 3.5.0+dfsg-9 |
yaraDebian:13 |
before 3.5.0+dfsg-9 | 3.5.0+dfsg-9 |
yaraDebian:14 |
before 3.5.0+dfsg-9 | 3.5.0+dfsg-9 |
yaraUbuntu:Pro:16.04:LTS |
before 3.4.0+dfsg-2ubuntu0.1~esm1, plus listed versions 3.4.0+dfsg-23.4.0+dfsg-2build1 |
3.4.0+dfsg-2ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-5924 is a high vulnerability (CVSS 7.5) in Virustotal Yara, published April 3, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.59%, the 75th percentile. Fixed in yara 3.5.0+dfsg-9.
References
github.com/VirusTotal/yara/commit/7f02eca670f29c00a1d2c305e96febae6ce5d37b
securityfocus.com/bid/98075
github.com/VirusTotal/yara/issues/593
nvd.nist.gov/vuln/detail/CVE-2017-5924
github.com/advisories/GHSA-33qw-wpjx-355w
security-tracker.debian.org/tracker/CVE-2017-5924
ubuntu.com/security/CVE-2017-5924
cve.org/CVERecord?id=CVE-2017-5924
ubuntu.com/security/notices/USN-8080-1