CVE-2017-6188
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting...
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.5
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
- Record
CVE-2017-6188- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 1.9 Low
AV:L/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
- Record
CVE-2017-6188- Updated
- 2026-11-02
EUVDEUVD-2017-15253 No score
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
- Record
EUVD-2017-15253- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vpvg-79jp-cjw8
5.5
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting...
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
- Record
GHSA-vpvg-79jp-cjw8- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
5.5
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
- Record
CVE-2017-6188- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-6188
5.5
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
- Record
DEBIAN-CVE-2017-6188- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2017-6188
5.5
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
- Record
UBUNTU-CVE-2017-6188- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 3.0
- 4.7 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVMGASA-2017-0101 No score
Updated munin packages fix security vulnerability
Stevie Trujillo discovered a local file write vulnerability in munin, a network-wide graphing framework, when CGI graphs are enabled. GET parameters are not properly handled, allowing to inject options into munin-cgi-graph and overwriting any file accessible by the user running the cgi-process (CVE-2017-6188).
- Record
MGASA-2017-0101- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11067-1 No score
munin-2.0.66-3.5 on GA media
These are all security issues fixed in the munin-2.0.66-3.5 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11067-1- Updated
- 2026-11-02
OSVUSN-3215-1 No score
munin vulnerability
It was discovered that Munin incorrectly handled CGI graphs. A remote attacker could use this issue to overwrite arbitrary files as the www-data user.
- Record
USN-3215-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
muninDebian:12 |
before 2.0.31-1 | 2.0.31-1 |
muninDebian:13 |
before 2.0.31-1 | 2.0.31-1 |
muninDebian:14 |
before 2.0.31-1 | 2.0.31-1 |
muninDebian:7 |
before 2.0.6-4+deb7u3, plus listed versions 2.0.6-42.0.6-4+deb7u12.0.6-4+deb7u1~bpo60+12.0.6-4+deb7u22.0.6-4+deb7u2~bpo60+1 |
2.0.6-4+deb7u3 |
muninDebian:8 |
before 2.0.25-1+deb8u1, plus listed versions 2.0.25-12.0.25-1+deb8u1~bpo70+1 |
2.0.25-1+deb8u1 |
muninMageia:5 |
before 2.0.25-1.1.mga5 | 2.0.25-1.1.mga5 |
muninUbuntu:14.04:LTS |
before 2.0.19-3ubuntu0.2, plus listed versions 2.0.17-2ubuntu12.0.17-3ubuntu12.0.18-1ubuntu12.0.19-22.0.19-3 |
2.0.19-3ubuntu0.2 |
muninUbuntu:16.04:LTS |
before 2.0.25-2ubuntu0.16.04.2, plus listed versions 2.0.25-12.0.25-2 |
2.0.25-2ubuntu0.16.04.2 |
muninopenSUSE:Tumbleweed |
before 2.0.66-3.5 | 2.0.66-3.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-6188 is a medium vulnerability (CVSS 5.5) in Munin-monitoring Munin, published February 22, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.42%, the 36th percentile. Fixed in munin 2.0.31-1.
References
securityfocus.com/bid/96399
bugs.debian.org/855705
debian.org/security/2017/dsa-3794
security.gentoo.org/glsa/201710-05
github.com/munin-monitoring/munin/issues/721
nvd.nist.gov/vuln/detail/CVE-2017-6188
Show 8 moreShow less
github.com/advisories/GHSA-vpvg-79jp-cjw8
security-tracker.debian.org/tracker/CVE-2017-6188
advisories.mageia.org/MGASA-2017-0101.html
bugs.mageia.org/show_bug.cgi?id=20335
ubuntu.com/security/CVE-2017-6188
ubuntu.com/security/notices/USN-3215-1
cve.org/CVERecord?id=CVE-2017-6188
suse.com/security/cve/CVE-2017-6188