Every CVE Search/ Get API key

CVE-2017-6369

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2...

8.8 HighFix available

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.30%Up 1.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

Record
CVE-2017-6369
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-862
Updated
2026-11-02
CVE List No score

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

Record
CVE-2017-6369
Updated
2026-11-02
EUVDEUVD-2017-15430 No score

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

Record
EUVD-2017-15430
Updated
2026-11-03
GitHub AdvisoriesGHSA-vf42-c4fw-rcm3 8.8

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2...

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

Record
GHSA-vf42-c4fw-rcm3
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-862
Updated
2026-11-02
OSV 8.8

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

Record
CVE-2017-6369
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-6369 8.8

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

Record
DEBIAN-CVE-2017-6369
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2017-6369 8.8

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

Record
UBUNTU-CVE-2017-6369
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVSUSE-SU-2017:1156-1 No score

Security update for firebird

This update for firebird fixes the following security issues:

  • CVE-2017-6369: Insufficient checks in the UDF subsystem in Firebird allowed remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so (bsc#1023990).
Record
SUSE-SU-2017:1156-1
Updated
2026-11-02
OSVUSN-3929-1 No score

firebird2.5 vulnerabilities

It was discovered that Firebird incorrectly handled certain malformed packets. A remote attacker could possibly use this issue with a specially crafted network packet to cause Firebird to crash, resulting in a denial of service. (CVE-2014-9323)

It was discovered that Firebird incorrectly handled certain UDF libraries. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2017-6369)

Record
USN-3929-1
Updated
2026-11-02
OSVUSN-4822-1 No score

firebird2.5 vulnerability

It was discovered that Firebird exposed certain UDF libraries. An authenticated attacker could use this vulnerability to cause a denial of service (crash) or possibly execute arbitrary code.

Record
USN-4822-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
firebird3.0
Debian:12
before 3.0.1.32609.ds4-14
3.0.1.32609.ds4-14
firebird3.0
Debian:13
before 3.0.1.32609.ds4-14
3.0.1.32609.ds4-14
firebird3.0
Debian:14
before 3.0.1.32609.ds4-14
3.0.1.32609.ds4-14
firebird2.5
Debian:7
before 2.5.2.26540.ds4-1~deb7u3, plus listed versions
2.5.2.26540.ds4-1~deb7u12.5.2.26540.ds4-1~deb7u22.5.2~svn+54698.ds4-3
2.5.2.26540.ds4-1~deb7u3
firebird2.5
Debian:8
before 2.5.3.26778.ds4-5+deb8u1, plus listed versions
2.5.3.26778.ds4-5
2.5.3.26778.ds4-5+deb8u1
firebird-classic
SUSE:Linux Enterprise Desktop 12 SP1
before 2.5.2.26539-15.1
2.5.2.26539-15.1
firebird-classic
SUSE:Linux Enterprise Desktop 12 SP2
before 2.5.2.26539-15.1
2.5.2.26539-15.1
firebird
SUSE:Linux Enterprise Software Development Kit 12 SP1
before 2.5.2.26539-15.1
2.5.2.26539-15.1
firebird-classic
SUSE:Linux Enterprise Software Development Kit 12 SP1
before 2.5.2.26539-15.1
2.5.2.26539-15.1
firebird-classic
SUSE:Linux Enterprise Software Development Kit 12 SP2
before 2.5.2.26539-15.1
2.5.2.26539-15.1
Show 5 moreShow less
Affected packages
PackageAffectedFixed
firebird-classic
SUSE:Linux Enterprise Workstation Extension 12 SP1
before 2.5.2.26539-15.1
2.5.2.26539-15.1
firebird-classic
SUSE:Linux Enterprise Workstation Extension 12 SP2
before 2.5.2.26539-15.1
2.5.2.26539-15.1
firebird2.5
Ubuntu:14.04:LTS
before 2.5.2.26540.ds4-9ubuntu1.1, plus listed versions
2.5.2.26540.ds4-32.5.2.26540.ds4-72.5.2.26540.ds4-82.5.2.26540.ds4-8ubuntu12.5.2.26540.ds4-8ubuntu22.5.2.26540.ds4-9ubuntu1
2.5.2.26540.ds4-9ubuntu1.1
firebird2.5
Ubuntu:Pro:16.04:LTS
before 2.5.4.26856.ds4-1ubuntu0.1~esm1, plus listed versions
2.5.4.26856.ds4-1build1
2.5.4.26856.ds4-1ubuntu0.1~esm1
firebird2.5
Ubuntu:14.04:LTS
From an advisory covering 2 CVEs
before 2.5.2.26540.ds4-9ubuntu1.1, plus listed versions
2.5.2.26540.ds4-32.5.2.26540.ds4-72.5.2.26540.ds4-82.5.2.26540.ds4-8ubuntu12.5.2.26540.ds4-8ubuntu22.5.2.26540.ds4-9ubuntu1
2.5.2.26540.ds4-9ubuntu1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-6369 is a high vulnerability (CVSS 8.8) in Firebirdsql Firebird, published March 24, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.30%, the 88th percentile. Fixed in firebird3.0 3.0.1.32609.ds4-14.

References

Show 9 moreShow less
MoveEnter Open