Every CVE Search/ Get API key

CVE-2017-6802

An issue was discovered in ytnef before 1.9.2. There is a potential heap-based buffer over-read...

7.5 HighFix available

An issue was discovered in ytnef before 1.9.2. There is a potential heap-based buffer over-read on incoming Compressed RTF Streams, related to DecompressRTF() in libytnef.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.42%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

An issue was discovered in ytnef before 1.9.2. There is a potential heap-based buffer over-read on incoming Compressed RTF Streams, related to DecompressRTF() in libytnef.

Record
CVE-2017-6802
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

An issue was discovered in ytnef before 1.9.2. There is a potential heap-based buffer over-read on incoming Compressed RTF Streams, related to DecompressRTF() in libytnef.

Record
CVE-2017-6802
Updated
2026-11-02
EUVDEUVD-2017-15856 No score

An issue was discovered in ytnef before 1.9.2. There is a potential heap-based buffer over-read on incoming Compressed RTF Streams, related to DecompressRTF() in libytnef.

Record
EUVD-2017-15856
Updated
2026-11-03
GitHub AdvisoriesGHSA-hm69-vmvv-v8qp 7.5

An issue was discovered in ytnef before 1.9.2. There is a potential heap-based buffer over-read...

An issue was discovered in ytnef before 1.9.2. There is a potential heap-based buffer over-read on incoming Compressed RTF Streams, related to DecompressRTF() in libytnef.

Record
GHSA-hm69-vmvv-v8qp
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 7.5

An issue was discovered in ytnef before 1.9.2. There is a potential heap-based buffer over-read on incoming Compressed RTF Streams, related to DecompressRTF() in libytnef.

Record
CVE-2017-6802
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-6802 7.5

An issue was discovered in ytnef before 1.9.2. There is a potential heap-based buffer over-read on incoming Compressed RTF Streams, related to DecompressRTF() in libytnef.

Record
DEBIAN-CVE-2017-6802
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2017-6802 7.5

An issue was discovered in ytnef before 1.9.2. There is a potential heap-based buffer over-read on incoming Compressed RTF Streams, related to DecompressRTF() in libytnef.

Record
UBUNTU-CVE-2017-6802
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2017-0174 No score

Updated libytnef packages fix security vulnerabilities

Several issues were discovered in libytnef, a library used to decode application/ms-tnef e-mail attachments. Multiple heap overflows, out-of-bound writes and reads, NULL pointer dereferences and infinite loops could be exploited by tricking a user into opening a maliciously crafted winmail.dat file (CVE-2017-6298, CVE-2017-6299, CVE-2017-6300, CVE-2017-6301, CVE-2017-6302, CVE-2017-6303, CVE-2017-6304, CVE-2017-6305, CVE-2017-6306, CVE-2017-6800, CVE-2017-6801, CVE-2017-6802).

A heap-buffer-overflow vulnerability in libytnef due to an incorrect boundary checking in SIZECHCK macro in lib/ytnef.c (CVE-2017-9058).

Record
MGASA-2017-0174
Updated
2026-11-02
OSVUSN-3288-1 No score

libytnef vulnerabilities

It was discovered that libytnef incorrectly handled malformed TNEF streams. If a user were tricked into opening a specially crafted TNEF attachment, an attacker could cause a denial of service or possibly execute arbitrary code.

Record
USN-3288-1
Updated
2026-11-02
OSVUSN-4615-1 No score

libytnef vulnerabilities

It was discovered that Yerase's TNEF had null pointer dereferences, infinite loop, buffer overflow, out of bounds reads, directory traversal issues and other vulnerabilities. An attacker could use those issues to cause a crash and consequently a denial of service. (CVE-2017-6298, CVE-2017-6299, CVE-2017-6300, CVE-2017-6301, CVE-2017-6302, CVE-2017-6303, CVE-2017-6304, CVE-2017-6305, CVE-2017-6306, CVE-2017-6800, CVE-2017-6801, CVE-2017-6802)

Record
USN-4615-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libytnef
Debian:12
before 1.9.2-1
1.9.2-1
libytnef
Debian:13
before 1.9.2-1
1.9.2-1
libytnef
Debian:14
before 1.9.2-1
1.9.2-1
libytnef
Debian:7
before 1.5-4+deb7u1, plus listed versions
1.5-4
1.5-4+deb7u1
libytnef
Debian:8
before 1.5-6+deb8u1, plus listed versions
1.5-6
1.5-6+deb8u1
libytnef
Mageia:5
before 1.5-10.2.mga5
1.5-10.2.mga5
libytnef
Ubuntu:14.04:LTS
before 1.5-6ubuntu0.1, plus listed versions
1.5-51.5-6
1.5-6ubuntu0.1
libytnef
Ubuntu:16.04:LTS
before 1.5-9ubuntu0.1, plus listed versions
1.5-61.5-9
1.5-9ubuntu0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-6802 is a high vulnerability (CVSS 7.5) in Ytnef Project Ytnef, published March 10, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.42%, the 72nd percentile. Fixed in libytnef 1.9.2-1.

References

Show 21 moreShow less
MoveEnter Open