Every CVE Search/ Get API key

CVE-2017-6807

mod_auth_mellon before 0.13.1 is vulnerable to a Cross-Site Session Transfer attack, where a user...

6.1 MediumFix available

mod_auth_mellon before 0.13.1 is vulnerable to a Cross-Site Session Transfer attack, where a user with access to one web site running on a server can copy their session cookie to a different web site on the same server to get access to that site.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.07%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

mod_auth_mellon before 0.13.1 is vulnerable to a Cross-Site Session Transfer attack, where a user with access to one web site running on a server can copy their session cookie to a different web site on the same server to get access to that site.

Record
CVE-2017-6807
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

mod_auth_mellon before 0.13.1 is vulnerable to a Cross-Site Session Transfer attack, where a user with access to one web site running on a server can copy their session cookie to a different web site on the same server to get access to that site.

Record
CVE-2017-6807
Updated
2026-11-02
EUVDEUVD-2017-15861 No score

mod_auth_mellon before 0.13.1 is vulnerable to a Cross-Site Session Transfer attack, where a user with access to one web site running on a server can copy their session cookie to a different web site on the same server to get access to that site.

Record
EUVD-2017-15861
Updated
2026-11-03
GitHub AdvisoriesGHSA-25ph-rcq4-c44c 6.1

mod_auth_mellon before 0.13.1 is vulnerable to a Cross-Site Session Transfer attack, where a user...

mod_auth_mellon before 0.13.1 is vulnerable to a Cross-Site Session Transfer attack, where a user with access to one web site running on a server can copy their session cookie to a different web site on the same server to get access to that site.

Record
GHSA-25ph-rcq4-c44c
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

mod_auth_mellon before 0.13.1 is vulnerable to a Cross-Site Session Transfer attack, where a user with access to one web site running on a server can copy their session cookie to a different web site on the same server to get access to that site.

Record
CVE-2017-6807
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2017-6807 6.1

mod_auth_mellon before 0.13.1 is vulnerable to a Cross-Site Session Transfer attack, where a user with access to one web site running on a server can copy their session cookie to a different web site on the same server to get access to that site.

Record
DEBIAN-CVE-2017-6807
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2017-6807 6.1

mod_auth_mellon before 0.13.1 is vulnerable to a Cross-Site Session Transfer attack, where a user with access to one web site running on a server can copy their session cookie to a different web site on the same server to get access to that site.

Record
UBUNTU-CVE-2017-6807
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUSN-4597-1 No score

libapache2-mod-auth-mellon vulnerabilities

François Kooman discovered that mod_auth_mellon incorrectly handled cookies. An attacker could possibly use this issue to cause a Cross-Site Session Transfer attack. (CVE-2017-6807)

It was discovered that mod_auth_mellon incorrectly handled certain requests. An attacker could possibly use this issue to redirect a user to a malicious URL. (CVE-2019-3877)

It was discovered that mod_auth_mellon incorrectly handled certain requests. An attacker could possibly use this issue to access sensitive information. (CVE-2019-3878)

Record
USN-4597-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libapache2-mod-auth-mellon
Debian:12
before 0.12.0-2
0.12.0-2
libapache2-mod-auth-mellon
Debian:13
before 0.12.0-2
0.12.0-2
libapache2-mod-auth-mellon
Debian:14
before 0.12.0-2
0.12.0-2
libapache2-mod-auth-mellon
Ubuntu:16.04:LTS
before 0.12.0-2+deb9u1build0.16.04.1, plus listed versions
0.10.0-10.11.0-10.12.0-1
0.12.0-2+deb9u1build0.16.04.1
libapache2-mod-auth-mellon
Ubuntu:16.04:LTS
From an advisory covering 3 CVEs
before 0.12.0-2+deb9u1build0.16.04.1, plus listed versions
0.10.0-10.11.0-10.12.0-1
0.12.0-2+deb9u1build0.16.04.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-6807 is a medium vulnerability (CVSS 6.1) in Uninett Mod Auth Mellon, published March 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.07%, the 64th percentile. Fixed in libapache2-mod-auth-mellon 0.12.0-2.

References

Show 5 moreShow less
MoveEnter Open